You may receive an error message when you browse an IIS 6.0 Web site (835987)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems


SYMPTOMS

When you browse a Microsoft Internet Information Services (IIS) 6.0 Web site, you may receive an error message that is similar to the following:
The page cannot be found. HTTP 400 - Bad Request
Note If the Show friendly HTTP error messages check box is not selected in Microsoft Internet Explorer, you may receive an error message that is similar to the following:
Bad Request (Invalid Header Name)

CAUSE

This problem occurs when the browser sends a linear white space to the IIS 6.0 Web server, and the linear white space is between the HTTP request line and the start of the HTTP request header. For example, this problem may occur if the browser sends a space character (0x20) that is between the HTTP request line and the start of the HTTP request header. Subsequently, IIS 6.0 interprets the space character that is between the HTTP request line and the start of the HTTP request header as not valid.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit versions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Feb-2004  18:44  5.2.3790.131      337,408  Http.sys

Windows Server 2003, Enterprise Edition for Itanium-based Systems

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Feb-2004  18:44  5.2.3790.131      855,040  Http.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB835987 kbAudITPRO kbAudEndUser