"The address could not be found" error messages are logged to the gatherer log after you update a content index in SharePoint Portal Server 2003 (835521)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003

SYMPTOMS

In your server farm deployment of Microsoft Office SharePoint Portal Server 2003, when you view the gatherer log of a content index after you update that content index, you may see error messages that are similar to the following:

Error Message 1

Date Time Modify sps://ServerName/site$$$people
The address could not be found, (0x80042617 - Error in PortalCrawl Web Service. )

Error Message 2

Date Time Modify http://ServerName
The address could not be found, (0x80042616 - Error in the Site Data Web Service.)

CAUSE

This problem may occur if you configure SharePoint Portal Server 2003 to use a proxy server when it creates full-text indexes of external Web sites, and if all the following conditions are true:
  • You specify the Bypass proxy server for local (intranet) addresses option.
  • In the Do not use proxy server for address beginning with box, you specify one or more URLs that start with an asterisk (*) wildcard character. For example, you specify a URL that is similar to the following:

    *.DomainName.com

In this scenario, SharePoint Portal Server 2003 does not process the asterisk (*) wildcard character correctly when it crawls content.

WORKAROUND

To work around this problem, do not use an asterisk (*) wildcard character in URLs that you specify in the Do not use proxy server for address beginning with box. Instead, use one of the following prefixes in the URLs that you specify in the Do not use proxy server for address beginning with box, depending on your situation:
  • http://*.DomainName.com
  • https://*.DomainName.com

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

To configure SharePoint Portal Server 2003 to use a proxy server when it creates full-text indexes of external Web sites, use the Configure Server Farm Account Settings page in SharePoint Central Administration. For more information about how to configure proxy server settings in SharePoint Portal Server, see the "Configuring Server Farm Account Settings" topic in the "Managing Search" section of the "Administration" chapter of the Microsoft Office SharePoint Portal Server 2003 Administration Guide. The Microsoft Office SharePoint Portal Server 2003 Administration Guide (Administrator's Help.chm) is located in the Docs folder in the root directory of the SharePoint Portal Server 2003 CD.

For more information about SharePoint Portal Server 2003, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:9/9/2004
Keywords:kberrmsg kbnofix kbBug KB835521 kbAudITPRO