You receive multiple Event ID 1008 event messages from the Remote Access performance library (835446)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

SYMPTOMS

When you use Performance Monitor or another monitoring program to monitor a locked-down server, your event log may receive multiple event messages that are similar to the following event message: Event Type: Error
Event Source: Perflib
Event Category: None
Event ID: 1008
Date: Date_Of_Error
Time: Time_Of_Error
User: N/A
Computer: Computer_name
Description:
The Open Procedure for service"RemoteAccess" in DLL"C:\WINNT\System32\rasctrs.dll" failed. Performance data for this service will not be available. Status code returned is data DWORD 0.
Data:
0000: eb 03 00 00 ë These log entries occur at regular intervals as long as you use Performance Monitor.

CAUSE

This problem occurs because you the Remote Access Connection Manager Service is turned off. Therefore, the Rasctrs.dll file generates log errors against Perflib when you use Performance Monitor or another monitoring program to monitor a locked-down server.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   ------------------------------------------------------
   27-Jan-2004  20:32  5.0.2195.6894  13,072  Rasctrs.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New naming schema for Microsoft Windows update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbPerfMon kbBug kbfix kbQFE kbWin2000preSP5fix KB835446 kbAudITPRO