An Interix POSIX subsystem may fail and cause an access violation (835349)



The information in this article applies to:

  • Microsoft Windows Services for UNIX 3.0

SYMPTOMS

The POSIX subsystem may fail, and an access violation may occur. The POSIX subsystem does not fail every time, and the failure may occur very infrequently.

CAUSE

Some Interix programs are known to infrequently cause the POSIX subsystem to fail.

RESOLUTION

There is no known way to work around this problem. To restore the Interix environment, you must restart the computer. If you experience the symptoms that are described earlier, apply this hotfix.

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size    File name
   ---------------------------------------------------------
   03-Feb-2004  01:33  7.0.1701.29      131,072  Posix.exe  
   03-Feb-2004  01:34  7.0.1701.29      647,168  Psxss.exe  
 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbfix kbBug kbQFE KB835349 kbAudITPRO