Incorrect search behavior when users search for Lotus Notes documents in SharePoint Portal Server 2003 (834650)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003

SYMPTOMS

When you configure an IBM Lotus Notes database as a content source in Microsoft Office SharePoint Portal Server 2003, you may find that users experience incorrect search behavior when they search the portal site for Lotus Notes documents. For example, a Lotus Notes document is not returned in the search results when a user who has permission to the document searches the portal site. Or, a Lotus Notes document is returned in the search results when a user who does not have permission to the document searches the portal site.

CAUSE

This problem may occur if all the following conditions are true:
  • The Lotus Notes document is based on a template that contains one or more of the following:
    • A field whose type is set to Reader.
    • A field whose type is set to Author.
  • The Reader field and the Author field define additional readers and authors to the document.
In this situation, the Lotus Notes protocol handler does not retrieve the access control list (ACL) from the Reader field and the Author field.

RESOLUTION

This problem is corrected in Microsoft SharePoint Portal Server 2003 Service Pack 1.

To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

889380 How to obtain the latest service pack for SharePoint Portal Server 2003

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in SharePoint Portal Server 2003 Service Pack 1.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE KBHotfixServer kbSharePtPortalSvr2003SP1fix kbfix kbbug KB834650 kbAudITPRO