Unicode text files are not saved correctly from Internet Explorer 6.0 Service Pack 1 (834501)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows XP SP1

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you use Microsoft Internet Explorer 6.0 Service Pack 1 (SP1) to open a text file that contains Unicode characters, and then you try to save the file as a Unicode file, the file will not be saved in a true Unicode format.

When you open the Unicode text file in WordPad or in Microsoft Word, the text contains unreadable characters that are interspersed between the text characters. These characters may appear as small squares. If you open the file in Microsoft Office Excel 2003, you may receive the following error message:

This file is not in a recognizable format.
  • If you know the file is from another program which is incompatible with Microsoft Office Excel, click Cancel, then open this file in its original application. If you want to open the file later in Microsoft Office Excel, save it in a format that is compatible, such as text format.
  • If you suspect the file is damaged, click Help for more information about solving the problem.
  • If you still want to see what text is contained in the file, click OK. Then click Finish in the Text Import Wizard.

CAUSE

This problem occurs if you used Unicode encoding to save the text file from Internet Explorer 6.0 SP1. Internet Explorer does not add a Unicode signature to the file when Internet Explorer saves a plain text file. The saved file is not a Unicode document and cannot be processed as one.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   --------------------------------------------------------------
   21-Jul-2004  17:49  6.0.2800.1459   2,802,688  Mshtml.dll    

Registry subkeys that are required for this hotfix

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

After you install this hotfix, you must add the following information to one of several registry subkeys:

Key: FEATURE_PLAINTEXT_UNICODE_KB834501
Name: *
Type: REG_DWORD
Value: 1



Note You can also use "iexplore.exe" as the entry name to restrict the changes to just Internet Explorer.

To add the new registry information, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click any one of the following registry subkeys:
    • HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\FeatureControl
    • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
    • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\FeatureControl
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. On the Edit menu, point to New, and then click Key.
  4. Type FEATURE_PLAINTEXT_UNICODE_KB834501, and then press ENTER.
  5. Right-click FEATURE_PLAINTEXT_UNICODE_KB834501, click New, and then click DWORD Value.
  6. Type *, and then press ENTER.
  7. On the Edit menu, click Modify, type 1, and then click OK.
  8. Quit Registry Editor.

WORKAROUND

To work around this problem, follow these steps:
  1. Open the Unicode text file in Notepad.
  2. On the File menu, click Save as.
  3. In the Encoding list, click Unicode, and then click Save.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/13/2005
Keywords:kbtshoot kbRegistry kbQFE kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug KB834501 kbAudEndUser kbAudITPRO