Microsoft Project files take longer than you expect to open in Project 2003 (834445)



The information in this article applies to:

  • Microsoft Office Project Server 2003
  • Microsoft Office Project Professional 2003
  • Microsoft Office Project Standard 2003

SYMPTOMS

When you try to open a Microsoft Office Project 2003 project file, the file may take a longer than you expect to open.

For example, it may take two minutes or more to open the project file, where you might expect the file to open in several seconds.

Note The more project files that are contained in a database, the longer it may take to open a project file.

CAUSE

This problem may occur when the project file is contained in a very large database--for example, 100 gigabytes (GB).

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you installed the latest Project Server 2003 service pack, you do not have to install the hotfix.

Service pack information

This problem is corrected in Project Server 2003 Service Pack 1.

To resolve this problem, obtain the latest service pack for Project Server 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

873458 How to obtain the latest service pack for Project Server 2003

Hotfix information

How to obtain the hotfix

This issue is fixed in the Project 2003 Hotfix Package that is dated December 22, 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

833849 Description of Microsoft Office Project 2003 hotfix package: December 22, 2003

Note After you install this hotfix on the client computer, you must follow the steps that are listed in the "More Information" section of this article to activate the hotfix on the server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Project Server 2003 Service Pack 1.

MORE INFORMATION

To make sure that your Project Server has all the fixes that are contained in this update applied correctly, follow these steps:
  1. Run the self-extracting package, this will extract the files to a temporary folder that you select.
  2. For each Microsoft SQL query file (such as the Websps.sql file) that is extracted to the temporary folder that you indicated in step 1, do one of the following:
    • If you are using Microsoft SQL Server as the backend for your Project Server, follow these steps:
      1. On your main SQL server in your configuration, run SQL Query Analyzer.
      2. In the Database drop-down box, select the ProjectServer database.
      3. On the File menu, click Open, locate the SQL Query file (located in the temporary folder that is specified in step 1), and then open the file.
      4. On the Query menu, click Execute.
      5. When the query is finished running, quit Query Analyzer.
    • If you are using SQL Server Desktop Engine (also known as MSDE 2000) as the backend for your Project Server, follow these steps:
      1. On your main SQL server in your configuration, click Start, click Run, type osql -i <tempdir>\<queryfile>.sql -U sa in the Open box, and then click OK.

        For example, if you extracted the files in step 1 to C:\Temp and the name of the query file was Websps.sql, you would type osql -i c:\temp\websps.sql -U sa. This connects you to the local, default instance of MSDE 2000 by using the System Administrator account. You may also run osql with another username that has System Administrator permissions on the server.
      2. At the Password prompt, type the password for the account that you used in step a, and then press ENTER.
      3. This SQL query file that you specified in step a will now run.

Additional steps

To activate this hotfix, follow these steps:
  1. In Notepad, type or paste the following SQL code into a new file:

    declare @count as INT
    select @count = COUNT(name) from syscolumns where
       id = object_id('MSP_WEB_ADMIN') and 
       name='WADMIN_USE_BASELINE_SUMMARY_DATA'
    
    if @count = 0
       alter table MSP_WEB_ADMIN add WADMIN_USE_BASELINE_SUMMARY_DATA
        tinyint not null default 1
    
    GO
    
    update MSP_WEB_ADMIN set WADMIN_USE_BASELINE_SUMMARY_DATA = 0
    
    GO
    

  2. On the File menu, click Save As.
  3. Change the Save in box to the temporary folder that you selected in step 1 of the "More Information" section.
  4. In the File name box, type a name for your SQL file-for example, type Activate.sql.
  5. Change the Save as type box to Text Documents (*.txt).
  6. Click OK to save your SQL file.
  7. To activate this hotfix, perform step 2 in the "More Information" section for the new SQL file that you saved in steps 1 through 5.
To deactivate this hotfix, follow these steps:
  1. In Notepad, type or paste the following SQL code into a new file:

    update MSP_WEB_ADMIN set WADMIN_USE_BASELINE_SUMMARY_DATA = 1
    
    GO
    

  2. On the File menu, click Save As.
  3. Change the Save in box to the temporary folder that you selected in step 1 of the "More Information" section.
  4. In the File name box, type a name for your SQL file--for example, type Deactivate.sql.
  5. Change the Save as type box to Text Documents (*.txt).
  6. Click OK to save your SQL file.
  7. To deactivate this hotfix, perform step 2 in the "More Information" section for the new SQL file that you saved in steps 1 through 5.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbProjectServer2003SP1fix kbopenfile kbfix KB834445 kbAudEndUser