You cannot load a remote LMHOSTS file in Windows Server 2003 (834395)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

You may not be able to load an LMHOSTS file that is located on a remote server. This LMHOSTS file loads in Microsoft Windows 2000 Server, but does not load in Microsoft Windows Server 2003.

CAUSE

This problem occurs because Windows Server 2003 does not correctly read the LMHOSTS file at logon if the file points to an IP address as a host name. When Windows Server 2003 starts and loads a remote LMHOSTS file, it makes a null session connection to an IP address. Windows Server 2003 truncates the host name when you use IP address-to-IP address mapping in the LMHOSTS file.

The following is an example of an LMHOSTS file that does not load successfully in Windows Server 2003:

# --- LMHOSTS for Network A
# --- define IP addresses to servers with LMHOSTS on Public share
10.0.0.1  10.0.0.1  #PRE
# --- use LMHOSTS from the first successful access
#BEGIN_ALTERNATE
#INCLUDE \\10.0.0.1\Public\Network\Lmhosts.lab
#END_ALTERNATE


The following is an example of an LMHOSTS file that loads successfully in Windows Server 2003:

# --- LMHOSTS for Network A
# --- define IP addresses to servers with LMHOSTS on Public share
10.0.0.1  ServerName  #PRE
# --- use LMHOSTS from the first successful access
#BEGIN_ALTERNATE
#INCLUDE \\ServerName\Public\Network\Lmhosts.lab
#END_ALTERNATE

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name
   --------------------------------------------------------
   06-Jan-2004  00:40  5.2.3790.116      195,584  Netbt.sys x86
   06-Jan-2004  00:39  5.2.3790.116      534,528  Netbt.sys IA-64

WORKAROUND

To work around this problem, use a computer name instead of an IP address in the LMHOSTS file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB834395 kbAudITPRO