Certificate Services ignores the HighSerial registry entry after the first restart in Windows Server 2003 (834389)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you set the HighSerial registry entry value to change the length of the serial number that is assigned to certificates that the certification authority issues, Certificate Services must restart for the change to take effect. However, on subsequent restarts, the serial number has the default size.

CAUSE

This problem occurs because the certificate server checks the HighSerial registry entry only on the first restart after the registry entry is changed. The certificate server does not check the HighSerial registry entry on subsequent restarts. Therefore, the certificate server uses the default serial number length on subsequent restarts.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, 32-bit editions
   Date         Time   Version       Size     File name
   ------------------------------------------------------
   08-Jan-2004  20:19  5.2.3790.116  294,912  Certsrv.exe   
Windows Server 2003, 64-Bit Enterprise Edition
   Date         Time   Version       Size     File name  
   ------------------------------------------------------
   07-Jan-2004  17:41  5.2.3790.116  877,056  Certsrv.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbCertServices kbBug kbfix kbQFE kbWinServ2003preSP1fix KB834389 kbAudITPRO