Event ID 2051 and event ID 9045 are logged to the application event log after the MTA quits unexpectedly in Exchange Server 5.5 (834210)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

SYMPTOMS

The Microsoft Exchange message transfer agent (MTA) may quit unexpectedly on your Microsoft Exchange Server 5.5 computer. In this scenario, the following events are logged to the application event log:Source: MSExchangeMTA
Category: Internal Processing
Type: Error
Event ID: 2051
Description:
A fatal internal MTA error occurred. Contact Microsoft Technical Support. An illegal GET from element 486E2601 occurred at offset 1045. [BASE GATEWAY 36 67] (16) Source: MSExchangeMTA
Category: Field Engineering
Type: Error
Event ID: 9045
Description:
An unexpected error has occurred which may cause the MTA to terminate. Error: Access violation (0xc0000005) at Address 0x43418e reading from 0x4. [BASE GATEWAY 36] (16)

CAUSE

This problem may occur if your Exchange server tries to process an e-mail message in a scenario where both of the following conditions are true:
  • The Exchange MTA must process a long string of alternate recipients for the e-mail message.
  • The final alternate recipient for the e-mail message is a custom recipient. To send the message to the custom recipient, Exchange transports the message through the Microsoft Exchange Internet Mail Service.
For example, this problem may occur in a scenario that is similar to the following:
  1. You send an e-mail message to User1.
  2. User1 keeps a copy of the e-mail message and has User2 specified as an alternate recipient.
  3. User2 keeps a copy of the e-mail message and has User3 specified as an alternate recipient.
  4. User3 keeps a copy of the e-mail message and has User4 specified as an alternate recipient.
  5. User4 keeps a copy of the e-mail message and has User5 specified as an alternate recipient.
  6. User5 keeps a copy of the e-mail message and has User6@domain_name.com specified as an alternate recipient.
In this scenario, the MTA may quit unexpectedly when it tries to process the large address buffer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Exchange Server 5.5 Service Pack 4 (SP4).

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date		Time	Version		Size		File name
   ------------------------------------------------------------------
   01-Aug-2001 	17:02 			41,325 		Dbserver.sch 
   16-Sep-2002 	15:49 			88,248 		Dsadap.xv2 
   16-Sep-2002 	15:49 			33,049 		Edi.xv2 
   23-Jan-2004 	19:25 	5.5.2657.91 	1,941,776 	Emsmta.exe 
   23-Jan-2004 	19:04 	5.5.2657.91 	69,904 		Ems_rid.dll 
   13-Jun-2001 	17:05 			133,435 	Infoplog.cfg 
   23-Jan-2004 	19:05 	5.5.2657.91 	19,728 		Maxapia.dll 
   23-Jan-2004 	19:04 	5.5.2657.91 	12,048 		Maxapiv1.dll 
   23-Jan-2004 	19:27 	5.5.2657.91 	167,184 	Mtacheck.exe 
   23-Jan-2004 	19:05 	5.5.2657.91 	743,696 	Mtamsg.dll 
   23-Jan-2004 	19:05 	5.5.2657.91 	16,656 		Mtaperf.dll 
   18-Aug-2003 	19:03 			5,621 		Mtaperf.h 
   23-Jan-2004 	19:05 			52,082 		Mtaperf.ini 
   23-Jan-2004 	19:05 	5.5.2657.91 	16,656 		Mtxapia.dll 
   23-Jan-2004 	19:05 	5.5.2657.91 	11,536 		Mtxapiv1.dll 
   16-Sep-2002 	15:49 			36,452 		P2.tpl 
   13-Jun-2001 	17:06 			50,789 		P2.xv2 
   17-Sep-2001 	18:45 			14,002 		P42.tpl 
   16-Sep-2002 	15:49 			41,222 		P772.tpl 
   16-Sep-2002 	15:49 			9,028 		P772.xv2 
   29-Aug-2001 	18:16 			23,350 		Rdi.xv2 
   23-Jan-2004 	19:04 	5.5.2657.91 	322,320 	X400om.dll 
   23-Jan-2004 	19:04 	5.5.2657.91 	40,208 		X400omv1.dll 
   16-Sep-2002 	15:49 			31,276 		X500dap.tpl

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:10/3/2005
Keywords:kbHotfixServer kbQFE kbExchange550preSP5fix kbBug kbfix kbQFE KB834210 kbAudITPRO