"Operation terminated with error -614" error message when you start an Exchange 2000 server (834154)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

When you try to start a computer that is running Microsoft Exchange 2000 Server, all the following issues occur:
  • Exchange 2000 enters recovery mode, and the Microsoft Exchange Information Store service performs a soft recovery.
  • The Microsoft Exchange Information Store service does not start.
  • You receive the following error message:
    Operation terminated with error -614 (JET_errCheckpointDepthTooDeep, too many outstanding generations between checkpoint and current generation) after 899.914 seconds
  • The following event is recorded in the event log:Event Type: Error
    Event Source: MSExchangeIS
    Event Category: General
    Event ID: 9518
    Date: date
    Time: time
    User: N/A
    Computer: computer name
    Description:
    Error 0xfffffd9a starting Storage Group /DC=DC name/DC=DC name/DC=VE/CN=CONFIGURATION/CN=SERVICES/CN=MICROSOFT EXCHANGE/CN=FIRST ORGANIZATION/CN=ADMINISTRATIVE GROUPS/CN=FIRST ADMINISTRATIVE GROUP/CN=SERVERS/CN=CN name/CN=INFORMATIONSTORE/CN=FIRST STORAGE GROUP on the Microsoft Exchange Information Store. Storage Group - Initialization of Jet failed.

CAUSE

These issues may occur when the following conditions are all true:
  • The log files and the database were shut down correctly. There is no crash to recover from.
  • The E00.chk log checkpoint file has been deleted or renamed on the Exchange 2000 server.
  • There are more then 1,008 log files on the Exchange 2000 server.
When these issues occur, the Microsoft Exchange Information Store service performs a soft recovery and replays all log files during startup. Because the log files and the database were shut down correctly, there is no recovery to perform. Because there is no checkpoint, Exchange 2000 processes all the logs until Exchange 2000 reaches a record of a clean shutdown at the end. Because there are more than 1,008 log files, Exchange 2000 reaches this limit before Exchange 2000 can locate the record of a clean shutdown. Therefore, the issues that are described in the "Symptoms" section occur.

Note The issues that are described in the "Symptoms" section also occur if the conditions that are listed in this "Cause" section exist, and you replay the log files by using the eseutil /r command. The eseutil /r command also runs a soft recovery on the mailbox store.

WORKAROUND

To work around these issues, move the Exchange log files, and then restart your Exchange 2000 server. To do this, follow these steps:
  1. Make sure that all the databases are in a clean shutdown state before you move the log files. Run the eseutil /m command on each database and on each .stm file to check the state.
  2. Locate the Exchange Mdbdata folder.

    By default, this folder is located at C:\Program Files\Exchsvr\Mdbdata.
  3. This folder contains a sequential series of log files that starts with the E00.log log file. Select all the log files except for the first log file and the last five to 10 log files.
  4. Create a new folder, and then move the files that you selected in step 3 to the new folder.
  5. Restart the Exchange 2000 server. Ignore error messages that you receive during startup.

Modification Type:MajorLast Reviewed:5/4/2004
Keywords:kbprb KB834154