Speech accessibility utilities do not open menu commands in Windows XP (833528)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Tablet PC Edition

SYMPTOMS

Accessibility utilities may not be able to operate menu commands. Instead of opening the menu, the underlined letter (hotkey) of the menu command is inserted in the text area of the program. For example, when you say "File" to open the File menu in a program, the File menu does not open, and "f" appears in the text area of the program.

CAUSE

This problem may occur if you have applied security update MS03-045 (hotfix 824141).

For additional information about this security update, click the following article number to view the article in the Microsoft Knowledge Base:

824141 MS03-045: Buffer overrun in the ListBox and in the ComboBox control could allow code execution

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows XP Service Pack 1 installed to apply this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

IA-64
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   30-Jan-2004  21:23  5.1.2600.1337   5,623,936  Win32k.sys
x86
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   31-Jan-2004  00:23  5.1.2600.1337   1,678,208  Win32k.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbWinXPpreSP2fix kbUser kbinterop kbQFE kbfix kbBug KB833528 kbAudEndUser