The ENTER key on the numeric keypad does not work in a Telnet session (833515)



The information in this article applies to:

  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP 64-Bit Edition Version 2002 SP1

SYMPTOMS

When you press the ENTER key on the numeric keypad of your keyboard while you are in a Telnet session, nothing happens. However, the ENTER key on the main keyboard works as expected in this scenario.

CAUSE

This problem occurs when either of the following conditions is true:
  • You are running an East Asian language version of Microsoft Windows XP Service Pack 1 (SP1).
  • You are running an English version of Windows XP SP1 together with East Asian language support.
This problem occurs because of a code bug where the key-press event is not handled correctly in the telnet client program.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Microsoft Windows XP Service Pack 1 (SP1) to install this hotfix.

Restart requirement

You do not have to restart your computer after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows XP 32-bit editions
   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   08-Dec-2003  21:49  5.1.2600.1325      71,680  Telnet.exe     
Windows XP 64-Bit Edition
   Date         Time   Version            Size    File name    Platform
   ---------------------------------------------------------------------
   08-Dec-2003  21:49  5.1.2600.1325     196,096  Telnet.exe       IA-64
   08-Dec-2003  21:49  5.1.2600.1325      71,680  Wtelnet.exe      x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbQFE kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug KB833515 kbAudEndUser kbAudITPRO