Windows Explorer seems to stop responding after you remove a secondary hard disk drive (833394)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Professional SP1a
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Home Edition SP1a

SYMPTOMS

If you remove a secondary hard disk drive from a laptop computer in certain circumstances, the computer seems to stop responding. Specifically, if you remove a secondary hard disk drive from a disk drive bay in a laptop computer while the system is in a sleep state, Microsoft Windows Explorer seems to stop responding. The sleep state occurs when the computer is either on standby or is in hibernation. The computer may be unresponsive for as long as two minutes.

Additionally, the drive letter that represents the secondary hard disk drive is still visible in Windows Explorer.

CAUSE

This problem occurs because of an open handle on the removed volume when the system resumes.

RESOLUTION

Currently, there is no known resolution for this problem.

WORKAROUND

To work around this problem and to safely remove the hard disk drive, click the Safely Remove Hardware icon in the notification area. Remove the secondary hard disk drive before you put the system on standby or in hibernation.

Alternatively, turn off the computer to remove the secondary hard disk drive.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MajorLast Reviewed:1/21/2004
Keywords:kbprb kbPlugPlay kbHardware KB833394 kbAudEndUser