HOLD_CPU usage in the Indexing Service increases to 100 percent in Windows XP and in Windows Server 2003 (833228)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

On a Microsoft Windows XP-based or Microsoft Windows Server 2003-based computer that uses a removable memory storage device, you may find that, in certain situations, CPU usage in the Indexing Service (Cisvc.exe) increases to 100 percent.

CAUSE

This problem may occur if both the following conditions are true:
  • The removable memory storage device slot is empty and does not contain a removable memory storage device.
  • The Indexing Service is started.
In this situation, the Plug and Play (PNP) component generates mount notifications, and a nonpaged pool memory leak may occur.

RESOLUTION

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows XP

Date         Time   Version        Size       File name
--------------------------------------------------------
19-Dec-2003  18:32  5.1.2600.1330  1,350,144  Query.dll  

Windows XP 64-Bit Edition

Date         Time   Version         Size       File name
---------------------------------------------------------------
19-Dec-2003  18:37  5.1.2600.1330   4,942,336  Query.dll   IA-64
19-Dec-2003  18:32  5.1.2600.1330   1,350,144  Wquery.dll  x86

Note This hotfix requires Windows XP Service Pack 1.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB833228 kbAudITPRO kbAudEndUser