Some queries against the global catalog take longer to run than expected in Windows Server 2003 (833029)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you run a query against a global catalog on a Microsoft Windows Server 2003-based server, the query takes longer to run than expected.

CAUSE

This problem occurs because of the filter parsing order in the query string. When a filter in an AND term cannot be optimized, and when this filter appears at the beginning of the AND term, the whole AND term may be ignored. If you change the filter order in the AND term by moving the first filter to the last position, the filter is correctly processed. However, the last filter may be ignored when you do this.

RESOLUTION

Important This hotfix must be installed on all the Windows 2003 domain controllers that are in the domain.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003
   Date         Time   Version            Size    File name
   --------------------------------------------------------
   21-Jan-2004  00:13  5.2.3790.121    1,055,232  Esent.dll        
   21-Jan-2004  00:13  5.2.3790.123    1,527,296  Ntdsa.dll        
Windows Server 2003, 64-Bit Edition
   Date         Time   Version            Size    File name   Platform
   -------------------------------------------------------------------
   21-Jan-2004  00:15  5.2.3790.121    2,605,056  Esent.dll   IA-64
   21-Jan-2004  00:15  5.2.3790.123    4,037,120  Ntdsa.dll   IA-64

WORKAROUND

To work around this problem, reverse the order of the two filters so that the (displayName=Surname, First_Name) filter comes before the (homeMDB=*) filter in the query string.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB833029 kbAudITPRO