"New size of the attribute <GUID> exceeds the SQL server row limit of 8000 bytes" error message when you import customized attributes in Microsoft CRM (832753)



The information in this article applies to:

  • Microsoft Business Solutions CRM 1.0

SYMPTOMS

If you use Microsoft Business Solutions CRM Deployment Manager to create customizations, when you try to import these customizations to a second Microsoft CRM computer, the import may not succeed, and you may receive the following error message:
"An error occurred during the addition of the new field. The addition failed. For more information, see the event log."
Your computer may log a series of event messages in the event log. Event log entries may include the following event message: New size of the attribute ({GUID}) exceeds the SQL Server row limit of 8000 bytes. Failed to add new String attribute (Attribute Name) to Contact entity. Schema Editor failed to add the following attributes (List of attributes)

CAUSE

The problem occurs because of a miscalculation of the string attribute maximum size. As a result, the "max string lengths" are doubled during the import. If the row size of the entity where the new attributes are added as part of the import exceeds 8000 bytes, the import fails. Because you cannot remove customizations, there is no recovery. This update corrects the calculation error during the import.

RESOLUTION

Software update installation information

The following file is available for download from the Microsoft Download Center:
DownloadDownload the CRM 1.0 update package now.

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Install this update on the Microsoft CRM server. Make sure that the Microsoft Business Solutions CRM Deployment Manager is closed before you install this update. This hotfix supports the following Setup switches:
  • /? : Display the list of installation switches.
  • /u : Use Unattended mode.
  • /f : Force other programs to quit when the computer shuts down.
  • /z : Do not restart when the installation is complete.
  • /q : Use Quiet mode (no user interaction).
  • /x : Extract the files without running Setup.
For example, to install the hotfix without any user intervention, use the following command line:

CRM1.0-TK32140-Server-Windows2000.exe /u /q

To verify that the hotfix is installed on your computer, confirm that the following registry key exists:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Microsoft CRM\1.0\Server\SP0\TK32140

Removal information

You cannot remove this update.

Restart requirement

You do not have to restart your computer after you install this update.

File Information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name 
   -------------------------------------------------------
   19-Mar-2003  16:36  1.0.3017.101  186,952  DMSnapin.dll

Support Information

For technical support questions, visit the following Great Plains Web site, and then click New Support Request under Assisted Support: You can also contact Microsoft Business Solutions Technical Support by phone at 888-477-7877.

Modification Type:MinorLast Reviewed:9/29/2006
Keywords:kbMBSMigrate kbprb KB832753 kbAudDeveloper kbAudITPRO