The Information Store service does not mount all the databases and appears to remain in the Starting or Online Pending state in Exchange 2000 Server (832282)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

After you restart Microsoft Exchange 2000 Server, or when a clustered Exchange server fails over to another node, the Microsoft Exchange Information Store service does not start. Instead, the Information Store service (sometimes known as Store.exe) appears to remain in the Starting state or the Online Pending state.

When this problem occurs, for each database in each storage group that successfully mounts, you may find the following event in the application log: Event Type: Information
Event Source: MSExchangeIS Mailbox Store
Event Category: General
Event ID: 9523
Computer: ComputerName
Description:
The Microsoft Exchange Database "<StorageGroup>" has been started. You may also notice that at least one database never reports event ID 9523. Event ID 1001, an event that indicates that the Store.exe process started, is also not reported.

CAUSE

This issue may occur when an application or a service does not respond when the Store.exe process sends a system message that indicates that drive M has been mapped.

RESOLUTION

To resolve this problem, use one of the following methods:
  • Remove the mapping to drive M. For additional information about how to remove the mapping to drive M, click the following article number to view the article in the Microsoft Knowledge Base:

    305145 HOW TO: Remove the IFS Mapping for Drive M in Exchange 2000 Server

  • Identify the service or the configuration that causes the problem. To do so, follow these steps:
    1. Disable all the services and applications that are not required for Exchange to run, including all the antivirus services and applications.
    2. Make sure that the Information Store service operates correctly after you restore the failover cluster configuration.
    3. Enable each service and each application until you identify the one that is not responding to the system message.
  • Identify the application that is not responding to the system message. To do so, perform a kernel memory dump operation. Make sure that you perform the memory dump operation when the Information Store service is in the Starting state or the Online Pending state. For additional information about how to create a Memory.dmp file, click the following article number to view the article in the Microsoft Knowledge Base:

    244139 Windows Feature Allows a Memory.dmp File to Be Generated with the Keyboard


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

When the Information Store service maps drive M, the Store.exe process sends an operating system message to all the applications that are running, and the Information Store service enters a waiting state. The Information Store service remains in the waiting state until all the applications have responded to the system message.

Modification Type:MinorLast Reviewed:1/15/2004
Keywords:kbprb kbinfo kbBug KB832282 kbAudITPRO