The SAConfig.exe program does not change the computer name (832251)



The information in this article applies to:

  • Microsoft Server Appliance Kit (SAK), version 3.0

SYMPTOMS

When you create the SAConfig registry items based on the saconfigsample.reg registry file that is provided on the Server Appliance Kit (SAK) 3.0 CD in the OemTools\SAConfig\reg folder, if you run the SAConfig.exe -hostname -restart command, the computer restarts, but the computer name does not change.

CAUSE

This problem occurs because SAConfig.exe does not retrieve the required information from Windows Management Instrumentation (WMI).

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Version  Size     File name                 Platform
   -------------------------------------------------------------------------
   12-Jan-2004  09:44   1.3.1.4  118,819  154508_intl_i386_zip.exe  i386
   19-Nov-2003  23:51              8,989  Kb832251.zip

WORKAROUND

To work around this problem, follow these steps:
  1. Copy the OemTools\SAConfig\bin\SAConfig.exe and the OemTools\SAConfig\inf\SAConfig.inf files from the Server Appliance Kit 3.0 CD to a 3.5-inch disk.
  2. With the 3.5-inch disk still in the drive, open a command prompt, type drive:\saconfig -hostname -restart, and then press ENTER.

    Note In this command, drive is the drive letter for your 3.5-inch disk drive.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

REFERENCES

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbBug KB832251 kbAudITPRO