Some Devices Are Not Recognized When You Use Multiple IEEE 1394 (FireWire) Devices (830987)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

If you have multiple devices on the same computer that use the Institute of Electrical and Electronic Engineers (IEEE) 1394 high-speed serial bus (alternatively known as FireWire), some of the devices may not be recognized correctly.

When you use only one of these devices, Plug and Play loads the correct driver and the device works correctly. However, if you use two IEEE 1394 devices on your computer, the driver is not called a second time. Therefore, only the first device is recognized.

CAUSE

This problem may occur if the device IDs for the IEEE 1394 devices are similar. For example, this problem may occur if the first device has a unique ID (UID) of 200000002A30B00 and the second device has a UID of 210000001A30B00.

The 1394 device enumerator (1394bus.sys) has a device table that is implemented as a hash table that is stored in an array. The hash function calculates a hash based on the UID of the device. If there is a collision (if the hash values that are calculated for each device are the same), a larger table is allocated.

If two device IDs are similar, the hash calculation produces the same value for both devices. Therefore, a collision occurs and the code continually reallocates larger arrays up to the table size limit. Because the hash table reaches its size limit before the new entry for the second device is added to the table, the second device is not recognized.

RESOLUTION

Windows XP service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Windows XP or Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

  • For Windows XP, this hotfix requires Windows XP SP1a (SP1a).
  • For Windows Server 2003, there are no prerequisites.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Windows XP file information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name    Platform
   -----------------------------------------------------------------
   06-Nov-2003  18:42  5.1.2600.1317   51,072  1394bus.sys  x86
   06-Nov-2003  18:42  5.1.2600.1317  190,976  1394bus.sys  IA-64

Windows Server 2003 file information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name    Platform
   ----------------------------------------------------------------
   05-Nov-2003  19:46  5.2.3790.100   52,608  1394bus.sys  x86
   05-Nov-2003  19:45  5.2.3790.100  168,064  1394bus.sys  IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

After you install this hotfix, a hash calculation that has higher entropy is used for the device table. This behavior prevents the collisions that may occur if the IEEE 1394 device IDs are similar.

For more information about IEEE 1394 technology, visit the following Microsoft Web site:
For additional information about using IEEE 1394 devices with Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

310433 Using IEEE (FireWire) Devices with Windows XP

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New Naming Schema for Microsoft Windows Hotfix Packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates


Modification Type:MajorLast Reviewed:12/27/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbHardware kbQFE kbWinServ2003preSP1fix kbWinXPpreSP2fix kbfix kbbug KB830987 kbAudITPRO