"Access denied" error message when Exchange 2000 Instant Messaging users run the Rtcmcon.wsf script to export their contact list during an Exchange 2000 Instant Messaging migration (830835)



The information in this article applies to:

  • Microsoft Exchange 2000 Server


SYMPTOMS

During a migration from Microsoft Exchange 2000 Instant Messaging (IM) to Microsoft Office Live Communications Server 2003, when a user runs the Rtcmcon.wsf script to export their Exchange IM contact list to their contact list file on a network share, the export fails. The user receives the following error message on the client computer:
Access Denied
The user may also receive Windows Script Host error messages that are similar to the following:
Failed to open file \\ServerName\ShareName\FQDNUsername.txt
Error Source: Microsoft VBScript runtime error
Error Description: Permission denied

CAUSE

This behavior may occur if the following conditions are true:
  1. As a root domain administrator, when you run the Rtcish.wsf script to create contact list files for each Exchange IM user, you perform this procedure over a network share where you specify a drive letter and path of the script and the user file. For example, you type the following command:

    cscript MappedDrive\rtcish.wsf /usersfile:MappedDrive\UsersfileName

  2. After the script runs, you copy the resulting contact list files back over the network to the remote share on the destination home server.
When you copy the contact list files across the network, the contact list files lose their assigned permissions. If these contact list files are used during the migration, when a user tries to export their Exchange IM contact list by running the Rtcmcon.wsf script from a share on their home server, the export fails because the user does not have read and write permissions to their individual contact list file.

RESOLUTION

To resolve this behavior, follow these steps:
  1. Delete the contact list files that you copied over the network to the destination home server.
  2. Log on locally as the root domain administrator to the destination home server where you want to share the contact list files from.
  3. Rerun the Rtcish.wsf script from the destination home server.
When you follow this procedure, each user is automatically assigned read and write permissions to their individual contact list file. The administrator who runs the script is assigned full control permissions to each contact list.

MORE INFORMATION

Running the Rtcish.wsf script across the network is not a supported scenario. For detailed information about the correct procedure to migrate from Exchange IM, see the Microsoft white paper titled, "Migrating from Microsoft Exchange 2000 Instant Messaging to Microsoft Office Live Communications Server 2003". The white paper, named Migration.doc, is located on the Live Communications Server product CD-ROM, under the Migration folder.

Modification Type:MajorLast Reviewed:5/27/2004
Keywords:kbprb KB830835 kbAudITPRO kbAudEndUser