Backup fails on a computer that is running Small Business Server 2003 (830575)



The information in this article applies to:

  • Microsoft SQL Server 2000 (all editions)
  • Microsoft SQL Server 2000 Desktop Engine (MSDE)
  • Microsoft Windows Small Business Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition

SYMPTOMS

When you try to run a backup on a computer that is running Microsoft Small Business Server 2003, the backup may fail, and you may find events that are similar to the following in the application event log:
Event Type: Error
Event Source: VSS
Event Category: None
Event ID: 20
Date: 11/25/2003
Time: 05:09:59 PM
User: N/A
Computer: <ComputerName>
Description:
Volume Shadow Copy Service error: A critical component required by the
Volume Shadow Copy service is not registered. This might happened if an
error occurred during Windows setup or during installation of a Shadow Copy
provider. The error returned from CoCreateInstance on class with CLSID
{40700425-0080-11d2-851f-00c04fc21759} and Name MSSQL_ClientVirtualDeviceSet
is [0x80040154].


Event Type: Error
Event Source: VSS
Event Category: None
Event ID: 6008
Date: 11/25/2003
Time: 05:09:59 PM
User: N/A
Computer: <ComputerName>
Description:
Sqllib error: Failed to create VDS object. hr = 0x80040154.


Event Type: Information
Event Source: ESENT
Event Category: ShadowCopy
Event ID: 2001
Date: 11/25/2003
Time: 11:01:25 PM
User: N/A
Computer: <ComputerName>
Description:
wins (2140) Shadow copy 2 freeze started.


Event Type: Information
Event Source: ESENT
Event Category: ShadowCopy
Event ID: 2001
Date: 11/25/2003
Time: 05:10:21 PM
User: N/A
Computer: <ComputerName>
Description:
lsass (720) Shadow copy 2 freeze started.


Event Type: Information
Event Source: ESENT
Event Category: ShadowCopy
Event ID: 2001
Date: 11/25/2003
Time: 05:10:21 PM
User: N/A
Computer: <ComputerName>
Description:
certsrv.exe (1792) Shadow copy 2 freeze started.


Event Type: Information
Event Source: ESENT
Event Category: ShadowCopy
Event ID: 2003
Date: 11/25/2003
Time: 05:10:23 PM
User: N/A
Computer: <ComputerName>
Description:
lsass (720) Shadow copy 2 freeze stopped.


Event Type: Information
Event Source: ESENT
Event Category: ShadowCopy
Event ID: 2003
Date: 11/25/2003
Time: 05:10:23 PM
User: N/A
Computer: <ComputerName>
Description:
wins (2140) Shadow copy 2 freeze stopped.


Event Type: Information
Event Source: ESENT
Event Category: ShadowCopy
Event ID: 2003
Date: 11/25/2003
Time: 05:10:24 PM
User: N/A
Computer: <ComputerName>
Description:
certsrv.exe (1792) Shadow copy 2 freeze stopped.

Event Type: Information
Event Source: ESENT
Event Category: Logging/Recovery
Event ID: 210
Date: 11/25/2003
Time: 05:11:10 PM
User: N/A
Computer: <ComputerName>
Description:
certsrv.exe (1792) A full backup is starting.


Event Type: Error
Event Source: ESENT
Event Category: Logging/Recovery
Event ID: 215
Date: 11/25/2003
Time: 05:11:10 PM
User: N/A
Computer: <ComputerName>
Description:
certsrv.exe (1792) The backup has been stopped because it was halted by the
client or the connection with the client failed.
You may also receive the following error message when you try to run a backup of a SQL Server database:

Could not create component: x80040154
Check registration of SQLVDI.DLL and value of IID

CAUSE

This problem occurs when the backup program tries to use a Sqlvdi.dll file that has been unregistered. Typically, the Sqlvdi.dll file can become unregistered when you uninstall SQL Server Desktop Engine (also known as MSDE 2000) from a computer that is also running Microsoft SQL Server 2000.

RESOLUTION

To resolve this problem, re-register the Sqlvdi.dll file. To do so, follow these steps:
  1. Stop SQL Server.
  2. Click Start, click Run, type Regsvr32 Path\SQLVDI.DLL in the Open box, and then click OK. The default path of the Sqlvdi.dll file is C:\Program Files\Microsoft SQL Server\80\COM.
  3. Restart SQL Server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MajorLast Reviewed:2/25/2004
Keywords:kbnofix kbBug KB830575 kbAudITPRO