"RTC Server Snap-in Cannot Save Settings" Error Appears When You Configure a TLS or a TLS Mutual Connection (830530)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2003

SYMPTOMS

When you try to create a Microsoft Office Live Communications Server 2003 Transport Layer Security (TLS) or a TLS Mutual connection, you may receive the following error message when you click OK to save your changes:
RTC Server Snap-in cannot save some or all of the settings.

CAUSE

This behavior may occur if the private key is not included with the certificate that you select for the TLS or the TLS Mutual connection.

RESOLUTION

To resolve this issue, make sure that the certificate you want to use includes the private key. If the certificate was exported from another computer, make sure that the private key was exported with the certificate.

Some certificates do not permit you to export the private key together with the certificate. If you used the Microsoft Internet Information Services (IIS) Web Server Certificate Wizard to request a certificate, you must use the Web Server Certificate Wizard to complete the request and to obtain the private key.

MORE INFORMATION

To verify that the private key is included with your certificate, view the certificate information. To do so, follow these steps:
  1. Start the Live Communications Server utility.
  2. Expand Servers, right-click the server where you want to configure the TLS or the TLS Mutual connection, and then click Properties.
  3. On the Connections tab, click Add.
  4. In the Transport type list, click TLS, and then click Change Certificate.
  5. Click the certificate that you want to use, and then click View Certificate.
If the private key is included with the certificate, the following information appears in the certificate information on the General tab:You have a private key that corresponds to this certificate.

Modification Type:MajorLast Reviewed:10/17/2003
Keywords:kberrmsg kbprb KB830530 kbAudITPRO