Your Windows Messenger Status Information Is Not Correct, and You Do Not Receive Instant Messages (830526)



The information in this article applies to:

  • Microsoft Office Live Communications Server 2003

SYMPTOMS

When users view your presence information (the status of whether you are online and are available to communicate with) in Microsoft Windows Messenger, the information may be incorrect. For example, when your status should be displayed as Busy, other Windows Messenger clients may display your status as Online. Also, when another user sends you an instant message, you do not receive the message. This issue occurs even though you are online and are connected to Microsoft Office Live Communications Server 2003.

CAUSE

This issue may occur if you are connected to Live Communications Server by using a wireless network connection, and it occurs when the following events occur in the order that they are shown:
  1. Your connection to Live Communications Server is interrupted, and Windows Messenger is disconnected.
  2. Your connection to Live Communications Server is restored, and Windows Messenger is reconnected.
  3. You change your status in Windows Messenger. For example, you click your alias, and then click Busy.
In this scenario, other Windows Messenger users may still display your original status. For example, even though you have changed your status to Busy, your status may still appear as Online to other Windows Messenger users.

WORKAROUND

To work around this issue, wait until the Live Communications Server registration timeout interval expires (by default, a minimum of 5 minutes). When the registration timeout interval expires, endpoint information that is orphaned (or stale) is removed from the server. The correct presence information then appears to other Windows Messenger users. (Endpoints are the locations that users make their connection to Live Communications Server from.)

Optionally, you can modify the registration timeout interval on the computer that is running Live Communications Server. To do this, follow these steps:
  1. Start the Live Communications Server utility. To do this, click Start, point to Administrative Tools, and then click Live Communications Server.
  2. Right-click User Services and Global Settings, and then click Properties.
  3. Click the Registration tab, and then modify the timeout intervals in the Minimum box, the Default box, and the Maximum box.

    For additional information about each of the registration timeout interval settings, click Help in the User Services Global Settings Properties dialog box.
  4. Click OK.
Note Although presence information may be more accurate after you reduce the timeout intervals, network traffic and the load on Live Communications Server may increase. Microsoft has determined that the default settings are optimal for most Live Communications Server environments.

MORE INFORMATION

Live Communications Server supports the Multiple Points of Presence feature. This feature allows a user to log on from several endpoints and then combines that user's presence into an aggregate. Other Windows Messenger users see that logged-on user in one unified presence state.

If that logged on user is connected to Live Communications Server by using a wireless connection, and that wireless connectivity is lost, Live Communications Server is not notified of the logging off of that user's endpoint. When the wireless connection is restored, Windows Messenger may log on by using a new Endpoint Identifier (EPID). In this scenario, Live Communications Server combines the presence states of both endpoints (the new endpoint, and the original endpoint that existed before the user was disconnected). If the original endpoint has a higher rank of presence, this may be the status that appears to other Windows Messenger users. Also, if a user tries to send an instant message to that user, the message delivery is unsuccessful because Live Communications Server tries to send the message to the non-existent original endpoint.

Modification Type:MajorLast Reviewed:10/18/2003
Keywords:kbprb KB830526 kbAudITPRO