Your ISA Server 2000 server stops responding to SSL CONNECT requests (830221)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2000

SYMPTOMS

After a while, the Microsoft Internet Security and Acceleration (ISA) Server Web Proxy service may stop responding to Secure Sockets Layer (SSL) CONNECT requests from outbound clients. You have to restart the Web Proxy service to resolve the problem.

If you use System Monitor to view the Private Bytes counter and the Handle Count counter from the Process performance object for the W3proxy.exe process, you see that the values of these counters increase over time.

CAUSE

This problem may occur if the downstream ISA Server server is passing information upstream to another Web Proxy server, and the following steps occur:
  1. A Web Proxy client sends an SSL CONNECT request to open an SSL tunnel through the downstream and upstream proxies to a destination server.
  2. The Web Proxy client then receives a "200 Connection Established" response from the downstream Web Proxy server. This response indicates that the SSL tunnel was established successfully.
  3. The client then disconnects the SSL tunnel before any data is exchanged with the server.
Under these conditions, the connection from the downstream ISA server to the upstream proxy server may be left open, and other system resources may be consumed and not released.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next ISA Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, you must have ISA Server 2000 Service Pack 2 (SP2) installed on your computer.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name
   ------------------------------------------------------
   14-Jul-2004  17:41  3.0.1200.403  401,400  W3proxy.exe
This hotfix is also available for the French, German, Spanish, and Japanese versions of ISA Server 2000.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This hotfix includes the hotfix that is mentioned in the following Microsoft Knowledge Base article:

821098 Content cache issues on downstream ISA Server computer


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbfix kbbug KB830221 kbAudDeveloper kbAudEndUser kbAudITPRO kbAudOEM