Full or Incremental Crawl Is Not Completed in Full-Text Indexing (830182)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you turn on content indexing, and full-text indexing starts a full or an incremental crawl of the mailboxes on your Microsoft Exchange Server 2003 computer, after 24 hours have passed, very few of the documents or none of the documents on your Exchange 2003 computer have been indexed.

CAUSE

This behavior may occur if you have a third-party antispam program installed on your Exchange Server computer. Some antispam programs use mailboxes as message queues. Each message that the program keeps in the message queue is encrypted and contains many unique random keys that are indexed by the Microsoft Search service (MSSearch). This causes large index sizes, and the mail boxes that are used as message queues may cause MSSearch to stop responding when content indexing is turned on.

WORKAROUND

To work around this behavior, you must move the mailboxes that are being used as message queues by the third-party antispam program from the Exchange Stores that have full-text indexing turned on, delete the full-text index, and then re-create the full-text index.

Move the Message Queue Mailboxes

To move mailboxes on your Exchange 2003 computer, follow these steps:
  1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
  2. If the Display administrative groups option is turned on, expand Administrative Groups, and then expand First Administrative Group (where First Administrative Group is the name of your administrative group).

    Note To display administrative groups, right-click Your_Organization, click Properties, click to select the Display administrative groups check box, click OK two times, and then restart Exchange System Manager.
  3. Double-click Servers, and then locate the server container where the mailboxes of the antispam program are located.
  4. In the right pane, click the mailbox that you want to move. If you want to move more than one mailbox, press and hold CTRL, click each mailbox, and then release CTRL.
  5. Right-click the selected mailboxes, and then click Exchange Tasks.
  6. In the Exchange Task Wizard, click Next.
  7. On the Available Tasks page, under Select a task to perform, click Move Mailbox, and then click Next.
  8. On the Move Mailbox page, click a destination in the Server list, and then click a mailbox store in the Mailbox Store list.
  9. Click Next, configure how you want any corrupted messages that are found during the move to be handled, and then click Next two times.
For additional information about how to move a mailbox on Exchange Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:

821829 Moving Mailboxes in Exchange Server 2003

Delete and Re-Create the Full-Text Index

To delete and then re-create the full-text index, follow these steps:
  1. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
  2. If the Display administrative groups option is turned on, expand Administrative Groups, and then expand First Administrative Group (where First Administrative Group is the name of your administrative group).

    Note To display administrative groups, right-click Your_Organization, click Properties, click to select the Display administrative groups check box, click OK two times, and then restart Exchange System Manager.
  3. Expand Servers, expand the server that hosts the storage group that contains the mailbox store that you want to configure, expand Your_Storage_Group_Name, right-click Mailbox Store (ServerName), and then click Delete Full-Text Index.
  4. When you receive the Do you wish to continue? message, click Yes.
  5. Right-click Mailbox Store (ServerName), and then click Create Full-Text Index.
  6. Click OK to accept the default path of the catalog. Alternatively, type another path, and then click OK.
For additional information about how to create a full-text index, click the following article number to view the article in the Microsoft Knowledge Base:

822932 HOW TO: Configure Full-Text Indexing on Mailbox Stores in Exchange 2003

Move the MSSearch Files

The MSSearch files include the property store, the property store logs, the temporary directory, the index (catalog), and the gatherer logs. These files may be moved to another location. A white paper exists that contains more information about moving the MSSearch files. To download the Best Practices for Deploying Full-Text Indexing white paper, visit the following Microsoft Web site:

Start a Full Population

When you populate the index, the indexing process starts and produces a list of words that are held in the mailbox store database. These words are cross-referenced to the messages that contain the words. Microsoft recommends that you populate indexes when the Exchange 2003 computer is not being heavily used. To populate the index, follow these steps:
  1. Right-click Mailbox Store (ServerName), and then click Start Full Population.
  2. When you receive the Do you want to continue? message, click Yes.
You see activity on the Exchange 2003 computer while the index is created. After the activity has stopped, the new indexing statistics appear. This process can take several minutes or several hours. The duration depends on the number of documents that must be processed and the level of processing that is assigned to the indexing service.

Troubleshooting

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

If Exchange System Manager stops responding when you try to delete the full-text index, you may be not able to use Exchange System Manager to delete the full-text index. This problem occurs because the full-text index that you are trying to delete has stopped responding and MSSearch cannot process the delete request for the full-text index. As a result, Exchange System Manager stops responding also. To work around this problem, you can manually delete the full-text index that is affected. After you delete the full-text index in the registry, you can use Exchange System Manager to re-create the full-text index again. To manually delete the full-text index, follow these steps:

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Expand the following registry key:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Search\1.0

  3. In the right pane, right-click each registry key that has the same name as the full-text index that you want to remove, and then click Delete.
  4. Close Registry Editor.
  5. Click Start, point to Programs, point to Administrative Tools, and then click Services.
  6. In the Services list under Name, right-click Microsoft Search, and then click Stop.
  7. Wait for the Microsoft Search service to stop, right-click Microsoft Search, and then click Start.
  8. Wait for the Microsoft Search service to start, and then close Services.
  9. Click Start, point to Programs, point to Administrative Tools, and then click Event Viewer.
  10. Under Tree, click Application Log.
  11. In the right pane, double-click the Microsoft Search event, and then make sure that it does not indicate that it loaded the full-text index (catalog).
  12. Close Event Viewer.
  13. Click Start, point to Programs, point to Microsoft Exchange, and then click System Manager.
  14. If the Display administrative groups option is turned on, expand Administrative Groups, and then expand First Administrative Group (where First Administrative Group is the name of your administrative group).

    Note To display administrative groups, right-click Your_Organization, click Properties, click to select the Display administrative groups check box, click OK two times, and then restart Exchange System Manager.
  15. Expand Servers, expand the server that hosts the Full-Text Index that you want to configure, expand Your_Storage_Group_Name, expand Mailbox Store (ServerName), and then click Full-Text Indexing.
  16. Delete the working directory and the gatherer files that are associated with the full-text index that you want to remove.
  17. Right-click Mailbox Store (ServerName), and then click Create Full-Text Index.
  18. Click OK to accept the default path of the catalog. Alternatively, type another path, and then click OK.
  19. Right-click Mailbox Store (ServerName), and then click Start Full Population.
  20. When you receive the Do you want to continue? message, click Yes.

MORE INFORMATION

A white paper exists that contains more detailed information about full-text indexing. To download the Best Practices for Deploying Full-Text Indexing white paper, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:11/7/2005
Keywords:kbprb KB830182 kbAudITPRO