FIX: The keyword Best Bets that are returned in search results display incorrect URLs in SharePoint Portal Server 2003 (829877)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003

SYMPTOMS

After you add keyword Best Bets to a keyword to mark the items that are most relevant for that keyword, in certain situations you may find that a user who searches the portal by typing a keyword in the Enter keyword(s) box may receive unexpected search results. For example, the keyword Best Bets for that keyword may not display the correct URLs in the search results.

CAUSE

This problem may occur in situations where the keyword Best Bet is not processed correctly, and the value of the DAV:href property is incorrect.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you installed the latest SharePoint Portal Server 2003 service pack, you do not have to install the hotfix.

Service pack information

This problem is corrected in Microsoft SharePoint Portal Server 2003 Service Pack 1.

To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

889380 How to obtain the latest service pack for SharePoint Portal Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft SharePoint Portal Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version      Size       File name
------------------------------------------------------
03-Oct-2003  22:14  11.0.5704.3  2,268,224  Mssrch.dll

Note This hotfix requires Microsoft Office SharePoint Portal Server 2003.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.
This problem was first corrected in SharePoint Portal Server 2003 Service Pack 1.

MORE INFORMATION

For more information about how to manage keywords, see the "Managing Keywords" topic in the Microsoft Office SharePoint Portal Server 2003 Administration Guide. This topic is located in the "Managing Search Settings for the Portal" section of the "Managing Search Settings" section of the "Administration" chapter. The Microsoft Office SharePoint Portal Server 2003 Administration Guide (Administrator's Help.chm) is located in the Docs folder in the root directory of the SharePoint Portal Server 2003 CD.

For more information about SharePoint Portal Server, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbQFE kbSharePtPortalSvr2003SP1fix kbdisplay kbfix kbBug KB829877 kbAudITPRO