"10003: An error occurred while preparing to run the program" error message when you try to run an advertised program on Windows NT or Windows 2000 (829875)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

If you try to run an advertised program on a computer that is running Microsoft Windows NT 4.0 or Microsoft Windows 2000, you receive an error message that is similar to the following:
10003 An error occurred while preparing to run the program for advertisement "DEF20001" ("Test Running APP from Network Drive" - "Run TESTAPP from O: drive"). The operating system reported error 2147500037: Unspecified error Additional program properties: Command line: O:\TESTAPP.EXE Working directory: C:\WINNT\MS\SMS\clicomp\apa\Bin\ Drive letter (? = any): UNC
Possible cause: This message most commonly occurs when the program's command-line executable file could not be found, when a required drive letter connection to a distribution point could not be established, or when the program is configured to use the Software Installation Account but the account is not specified, could not be found, or does not have the appropriate permissions. Solution: Check each of the items listed above.

CAUSE

This problem may occur if both of the following conditions are true:
  • The command line of the advertised program includes a reference to a network path. For example, the path may be the following, where the user who is logged on has mapped O to a network share resource:

    O:\Setup.exe

  • The Run with administrative rights option is selected in the Environment properties of the advertised program.

WORKAROUND

If you advertise a program that has a command line that references a network resource directly, you can use either of the following two methods to work around this problem.

If the Program Does Not Require Administrative Rights to Run

On the Environment tab of the Program Properties dialog box, click to select the Run with user's rights option under Run Mode.

If the Program Requires Administrative Rights to Run

  1. On the Environment tab of the Program Properties dialog box, click to select the Run with administrative rights option under Run Mode.
  2. Click the Use Software Installation account option.
  3. In the Program text box, type the program's command line. Specify a valid UNC path, including the program name and any required parameters. For example, type the following:

    \\server\share\directory\setup.exe /parameter1 /parameter2

Note Before you can use the Software Installation account, you must do the following:
  1. Create a valid Software Installation account in a domain that is a member of at least one global group.
  2. Add the account that you created in step 1 to the Software Distribution Component. To do this, follow these steps:
    1. In the SMS Administrator Console, expand Site Database, expand Site Hierarchy, expand SiteName, and then expand Site Settings.
    2. Under Site Settings, click Component Configuration.
    3. In the right pane, right-click Software Distribution, and then click Properties. The Software Distribution dialog box appears.
    4. In the Software Distribution dialog box, click the General tab.
    5. On the General tab, add the Software Installation account, and then click OK.
  3. On the Environment tab of the Program Properties dialog box, set the Program can run option to Whether or not a user is logged in or Only when no user is logged in.

MORE INFORMATION

In a typical scenario, a user may try to run a command line from a network resource (other than a Microsoft Systems Management Server distribution point) that the user has access to. On a computer that is running Windows NT 4.0 or Windows 2000, if the Run with administrative rights option is selected in the Environment properties of the advertised program, the program must start under the context of the local SMSCliToknAcct& account. However, because the SMSCliToknAcct& account does not have access to network resources, the program cannot start.

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbprb KB829875 kbAudITPRO