You Cannot Use Fast User Switching After You Install Cisco Systems VPN Dialer Program (829715)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

After you install the Cisco Systems VPN Dialer program, you can no longer use the Fast User Switching feature in Microsoft Windows XP. If you try to turn on Fast User Switching, you receive a message stating that a program used CSGina.dll to disable the Fast User Switching and the Windows Welcome screen features.

Note By using Fast User Switching, multiple users of the same computer can quickly switch between their respective logons without actually logging off the computer, as long as it is not joined to a domain. Additionally, users do not have to quit the programs that they are running when they switch between logons by using Fast User Switching.

CAUSE

This issue occurs if the Microsoft Graphical Identification and Authentication file (Msgina.dll) is replaced by a third-party program. This issue occurs because when you install the Cisco Systems VPN Dialer program, it overwrites the Msgina.dll file with its own Graphical Identification and Authentication (GINA) filter driver file (CSGina.dll). Cisco Systems VPN Dialer requires the Csgina.dll file for the correct function of the VPN program.

Note This issue that is described in the "Symptoms" section of this article may also occur when you install other third-party programs that replace the Msgina.dll file.

WORKAROUND

To work around this issue, restore the Msgina.dll filter driver in the Windows registry, and then remove the Cisco Systems VPN Dialer program. To do so, follow these steps:
Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate, and then click the following registry sub key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

  3. Click File, click Export, type exported-winlogon-key in the File name box, and then click Save.
  4. In the right pane, right-click GinaDLL, and then click Delete.
  5. Quit Registry Editor.
  6. Use the Add or Remove Programs tool in Control Panel to remove Cisco Systems VPN Dialer.

MORE INFORMATION

For information about how to contact Cisco Systems, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z


Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:11/25/2003
Keywords:kbprb KB829715 kbAudEndUser kbAudITPRO