"WBEM_E_PROVIDER_FAILURE" error message when you use WMI to enumerate data from a remote computer in Windows 2000 (829707)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you use the Microsoft Windows Management Instrumentation (WMI) service, either directly or through a program, to enumerate data from a remote computer, you may receive the following error message:
WBEM_E_PROVIDER_FAILURE 0x80041004 (Provider Failure).

CAUSE

This problem occurs when the user of a remote computer tries to query the WMI service of a local computer by using the credentials of a local user account that has been created since the last time the WMI service was started.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Microsoft Windows 2000 Service Pack 4 (SP4) installed before you apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   25-Sep-2003  12:01  1.50.1085.115  172,126  Framedyn.dll

WORKAROUND

To work around this problem, restart the WMI services on the remote computer that is the target of the WMI request.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New Naming Schema for Microsoft Windows Hotfix Packages


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbRemoteProg kbBug kbfix kbQFE kbWin2000preSP5fix KB829707 kbAudEndUser