"Stop 0x0000008E" Error Message When a Terminal Services Client Prints a Document (829422)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

Your Microsoft Windows Server 2003-based server that is running Terminal Services in application mode may unexpectedly quit or stop responding. If you have configured Windows so that it does not automatically restart when a system failure occurs, you receive a Stop error message that is similar to the following:
Stop 0x0000008E
KERNEL_MODE_EXCEPTION_NOT_HANDLED

CAUSE

This problem may occur if both of the following conditions are true:
  • A user opens a Microsoft Word message attachment in Microsoft Outlook while the user is connected to the server through a Terminal Services session.

    -and-
  • The user prints the document to a network printer.
In this scenario, the printer driver may pass an invalid color adjustment object to Windows Server 2003. Windows quits or stops responding when the Win32k.sys driver tries to access this object.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to install this hotfix.

Restart Requirements

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   30-Sep-2003  21:46  5.2.3790.89     1,811,456  Win32k.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbprint kbBug kbfix kbQFE kbWinServ2003preSP1fix KB829422 kbAudITPRO