"Unable to read names from your Microsoft Exchange Server directory" error message when you create an organization chart in Visio 2003 using data from an Exchange Server folder (829225)



The information in this article applies to:

  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003, when used with:
    • Microsoft Office Outlook 2003

SYMPTOMS

In Microsoft Office Visio 2003, when you use the Organization Chart Wizard template to create an organization chart from information that is stored in a Microsoft Exchange Server directory, you may receive the following error message when you click A Microsoft Exchange Server directory, and then click Next:
Unable to read names from your Microsoft Exchange Server directory

CAUSE

This problem may occur if both of the following conditions are true:
  • The Use Cached Exchange Mode option in Microsoft Office Outlook 2003 is turned on.
  • The Outlook Address Book cache (.oab file) is not created on your hard disk yet. The Outlook Address Book cache is created in the following folder on your hard disk:

    Documents and Settings\UserName\Local Settings\Application Data\Microsoft\Outlook

By default, the Outlook Address Book is updated every 24 hours. This means that the Outlook Address Book cache is not created until 24 hours after you run Outlook for the first time. As a result, this issue may occur in situations when you install Outlook, and then you use the Organizational Chart Wizard template to create an organization chart from data that is stored in an Exchange Server directory before the Outlook Address Book cache is created.

WORKAROUND

To work around this problem, use one of the following methods, as appropriate to your situation.

Method 1: Turn Off the Use Cached Exchange Mode Option in Outlook

To turn off the Use Cached Exchange Mode option in Outlook, follow these steps:
  1. Start Outlook 2003 (if it is not already started).
  2. On the Tools menu, click E-Mail Accounts.
  3. Click View or change existing e-mail accounts, and then click Next.
  4. In the Outlook processes e-mail for these accounts in the following order list, click your Exchange Server e-mail account, and then click Change.
  5. Under Microsoft Exchange Server, click to clear the Use Cached Exchange Mode check box, click Next,, and then click Finish.
  6. Quit and then restart Outlook 2003.
  7. Start Visio 2003, and then use the Organizational Chart Wizard template to create an organization chart from data that is stored in your Exchange Server directory.

Method 2: Manually Synchronize the Outlook Address Book Cache

To manually synchronize the Outlook Address Book cache, follow these steps:
  1. Start Outlook 2003 (if it is not already started).
  2. On the Tools menu, point to Send/Receive, and then click Download Address Book.
  3. Click to select the Download changes since last Send/Receive check box (if it is not already selected).
  4. Under Information to download, click Full Details.
  5. Under Address book, in the Choose address book box, click \Global Address List, and then click OK.
  6. Start Visio 2003, and then use the Organizational Chart Wizard template to create an organization chart from data that is stored in your Exchange Server directory.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For more information about Visio 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:1/11/2006
Keywords:kberrmsg kbnofix kbBug KB829225 kbAudEndUser kbAudITPRO kbAudDeveloper