"Cannot Open Database Request" Error Message When You Use SMS Web Reporting (829218)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

Notice

SYMPTOMS

If you restore or move a Microsoft Systems Management Server (SMS) database from a failed SMS server to a new SMS server, and then reinstall SMS Web Reports on the server, you may receive the following error message when you try to run SMS Web Reports:
Cannot Open Database Request

CAUSE

This issue may occur when the smsschmusr_users account that the new SMS server uses does not have the correct credentials to access the imported SMS database.

RESOLUTION

To resolve this issue, use one of the following methods:

Delete the Smschmusr_Users Account

Delete the smsschmusr_users account from the database roles before you install SMS Web Reports. To delete the smsschmusr_users account, follow these steps:
  1. Click Start, click Programs, click Microsoft SQL Server, and then click Enterprise Manager.
  2. In the left pane of the Enterprise Manager screen, expand Microsoft SQL Servers, expand SQL Server Group, expand the SQL server that holds the SMS database, expand Databases, and then expand the SMS database.
  3. In the right pane, Click Roles, right-click smschm_users and then click Delete.
  4. Click Yes when you are prompted to confirm the deletion.
Note When you run SMS Web Reports, Setup re-creates the smschm_users account and its credentials.

Use the Sp_Change_Users_Login Stored Procedure

Use the sp_change_users_login stored procedure with the Auto_Fix switch. As a result, you link the user entry in the Sysusers tables of the database to a login of the same name that the Sysxlogins table contains. For more information about the sp_change_users_login stored procedure, see the Sp_Change_Users_Login topic in SQL Server 7.0 Books Online and SQL Server 2000 Books Online.

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbprb KB829218 kbAudITPRO