Crawl performance is slow in SharePoint Portal Server 2003 (829216)



The information in this article applies to:

  • Microsoft Office SharePoint Portal Server 2003

SYMPTOMS

You may find that in certain situations, it takes a longer time than you expect for Microsoft Office SharePoint Portal Server 2003 to crawl content in the portal site and update the content index. Performance is slow, although a hard disk, CPU, or network bottleneck does not exist.

CAUSE

This issue may occur if a proxy server is not configured for the search service in SharePoint Portal Server 2003 and a proxy server is configured in Microsoft Internet Explorer. When a proxy server is not configured for the search service in SharePoint Portal Server 2003, the account that is configured as the default content access account uses the proxy server settings that are configured in Internet Explorer.

WORKAROUND

To work around this issue, remove the proxy settings that are configured in Internet Explorer, and then restart the Microsoft SharePointPS Search service on the server. To do so, follow these steps:
  1. Remove the proxy settings that are configured in Internet Explorer. To do so, follow these steps:
    1. Start Internet Explorer (if it is not already started).
    2. On the Tools menu, click Internet Options.
    3. Click the Connections tab, and then click LAN Settings.
    4. Under Proxy server, click to clear the Use a proxy server for your LAN (These settings will not apply to dial-up or VPN connections) check box, and then click OK.
    5. Click OK.
  2. Restart the Microsoft SharePointPS Search service. To do so, follow these steps:
    1. Click Start, point to Administrative Tools, and then click Services.
    2. In the list of services, right-click Microsoft SharePointPS Search, and then click Restart.

MORE INFORMATION

For more information about how to administer and configure SharePoint Portal Server 2003, see the Microsoft Office SharePoint Portal Server 2003 Administration Guide. The Microsoft Office SharePoint Portal Server 2003 Administration Guide (Administrator's Help.chm) is located in the Docs folder in the root of the SharePoint Portal Server 2003 CD.

For more information about SharePoint Portal Server, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:1/9/2006
Keywords:kbPerformance kbnofix kbBug KB829216 kbAudITPRO