You Are Prompted for Your User Credentials When You Request a CGI Script (829011)



The information in this article applies to:

  • Microsoft Internet Information Services version 6.0

SYMPTOMS

You are prompted by the browser for your user credentials if both of the following conditions are true:
  • You are logged on locally to a computer that is running Microsoft Windows Server 2003.
  • You open a browser to request a Common Gateway Interface (CGI) script from the Microsoft Internet Information Services (IIS) server on the local computer.
If you use the same credentials that you used to log on locally to the computer, the CGI script is returned successfully.

CAUSE

The browser prompts for new credentials because IIS incorrectly returns a 401 Access Denied Error to the browser during the original request.

WORKAROUND

To work around this problem, use the same credentials that you used when you originally logged on to the local computer.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfix.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   10-Oct-2003  20:52  5.2.3790.91       129,536  Msv1_0.dll       

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbfix kbBug kbQFE kbWinServ2003preSP1fix KB829011 kbAudDeveloper