Cannot Connect to a Network Resource After You Change the Properties of a Network Connection (828728)



The information in this article applies to:

  • Microsoft Windows XP Professional

SYMPTOMS

If you open the properties of a network interface connection and then click to clear a check box (such as the Network Monitor Driver or the File and Printer Sharing check box) and then click to select the same check box, the change may appear to work as expected after you click OK. However, you may not be able to connect to a network resource.

Note To change the properties of a network interface connection, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Click Network and Internet Connections.
  3. Click Network Connections.
  4. Right-click the network connection you want to change, and then click Properties.

CAUSE

This problem may occur if you are a member of both the Administrators group and the Network Configuration Operators group.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP, 32-Bit Version

   Date         Time   Version        Size     File name
   -------------------------------------------------------
   17-Sep-2003  17:59  5.1.2600.1271  584,192  Netcfgx.dll 

Windows XP, 64-Bit Version

   Date         Time   Version        Size       File name     Platform
   --------------------------------------------------------------------
   17-Sep-2003  17:35  5.1.2600.1271  1,843,712  Netcfgx.dll   IA-64
   17-Sep-2003  17:59  5.1.2600.1271    584,192  Wnetcfgx.dll  x86 

WORKAROUND

To work around this problem, your administrator can remove you from the Network Configuration Operators group if you are a member of the Administrators group.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug KB828728 kbAudEndUser kbAudITPRO