FIX: You Cannot Rename a File After You Upload the File to an FTP Server (828086)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

If you upload a large file to an FTP server, and you try to rename the file immediately, you may receive the following error message:
550 The process cannot access the file because it is being used by another process.
The following entries are logged in the Microsoft Internet Information Services (IIS) log:
08:19:47 65.53.232.91 [4]RNFR myfile.zip 350 0 08:19:47 65.53.232.91 [4]RNTO myfile.zip.ftp 550 32
08:19:47 65.53.232.91 [4]QUIT - 550 0
08:19:47 65.53.232.91 [4]created /myfile.zip 226 0

CAUSE

This problem occurs because the first step in the rename process, RNFR (Rename From), for the Myfile.zip file starts before the put (or create) action of the Myfile.zip file is complete.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-Sep-2003  09:27  6.0.3790.82       119,808  Ftpsvc2.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB828086 kbAudDeveloper