FIX: Small delay when Windows Media Player 9 Series switches files that are streamed from a Windows Media Services 9 Series server (827560)



The information in this article applies to:

  • Microsoft Windows Media Player 9 Series for Windows XP
  • Microsoft Windows Media Player 9 Series for Windows 2000
  • Microsoft Windows Media Player 9 Series for Windows Millennium Edition
  • Microsoft Windows Media Player 9 Series for Windows Server 2003
  • Microsoft Windows Media Services 9 Series

SYMPTOMS

When you stream files from a Windows Media Services 9 Series server, you may notice a delay of five or six seconds when you switch between files. This delay may be an undesirable user experience.

CAUSE

This problem occurs because of the way that the Windows Media Player 9 Series server submits the client rendering log to the Windows Media Services 9 Series server. When the server is set up to accept client rendering logs, an internal error may be incorrectly reported on the client when the client waits for a response from the server. If this behavior occurs, the client times out after a default period and then opens the next file. In this case, the server receives the correct log from the client.

RESOLUTION

If client rendering logs are not important, you can turn off this functionality on the Windows Media Services server to resolve the problem. If this is not acceptable, a fix for the client is available.

For Microsoft Windows 2000, Microsoft Windows XP, and Microsoft Windows Server 2003

The following file is available for download from the Microsoft Download Center:

DownloadDownload the WindowsMedia9-KB827560-x86-ENU.exe package now.

For Microsoft Windows Millennium Edition (Me)

The following file is available for download from the Microsoft Download Center:

DownloadDownload the WindowsMedia9-KB827560-x86-ENU.exe package now.
For more information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   22-Aug-2003  08:45  9.0.0.3070  988,160  Wmnetmgr.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:7/25/2005
Keywords:kbdownload kbfix KB827560 kbAudDeveloper kbAudEndUser kbAudITPRO