The Windows Redirector May Cancel a Session During a Long-Lasting Locking Operation (827546)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

The Windows Redirector may incorrectly cancel a session during a long-lasting locking operation. This problem may occur when two clients access the same file on a server, where the following conditions are true:
  • "Client A" locks a file on the file server.
  • "Client B" also tries to lock the same file by calling the LockFileEx (hFile,LOCKFILE_EXCLUSIVE_LOCK) function.
  • The file server never returns the server message block call to client B because client A still has the file locked.
  • The client B Redirector times out and disconnects the session. (The time-out period is controlled by the Sesstimeout registry setting.)

CAUSE

This problem may occur if the LOCKFILE_FAIL_IMMEDIATELY flag in the LockFileEx function is not set and if the server returns the server message block only when the file has been successfully locked. If this takes longer than the client-side session time-out, the client's Redirector cancels the connection.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name             Platform
   ------------------------------------------------------------------------------
   25-Aug-2003  20:48  5.2.3790.80       395,264  Mrxsmb.sys            X86
   25-Aug-2003  20:48  5.2.3790.80       157,696  Rdbss.sys             X86
   12-Aug-2003  18:54                        271  Branches.inf          X86
   25-Aug-2003  22:39                     10,444  Kb827546.cat          X86
   25-Aug-2003  22:20                        354  Updatebr.inf          X86
   25-Aug-2003  22:20                      5,170  Update_rtmqfe.inf     X86
   25-Aug-2003  20:49  5.2.3790.80     1,121,792  Mrxsmb.sys            Ia64
   25-Aug-2003  20:48  5.2.3790.80       463,360  Rdbss.sys             Ia64
   25-Aug-2003  22:26                      5,190  Update_rtmqfe.inf     Ia64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB827546 kbAudITPRO