Windows XP Service Pack 1 and Windows Server 2003 wireless clients are not compatible with RSA Security Extensible Authentication Protocol (EAP) type (827537)



The information in this article applies to:

  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

When you try to connect a wireless client computer that is running Windows XP with Service Pack 1 (SP1) or Windows Server 2003 to a wireless network that is using the RSA Security Extensible Authentication Protocol (EAP) type, the wireless client cannot authenticate.

CAUSE

This problem occurs because the Protected EAP (PEAP) implementations in Windows XP SP1 and Windows Server 2003 are not compatible with the RSA Security EAP type for PEAP from RSA Security, Inc.

A fix is now available that permits wireless client computers that are running Windows XP with SP1 or Windows Server 2003 to authenticate by using the RSA Security EAP type for PEAP from RSA Security, Inc.

RESOLUTION

Windows XP service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP and Windows Server 2003 service packs that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   04-Nov-2003  15:27  5.1.2600.1316   92,672  Rastls.dll
   04-Nov-2003  15:27  5.1.2600.1313  136,704  Schannel.dll
Windows Server 2003
   Date         Time   Version      Size     File name   Platform
   --------------------------------------------------------------
   04-Nov-2003  18:01  5.2.3790.99  158,720  Rastls.dll  x86
   04-Nov-2003  18:01  5.2.3790.99  354,304  Rastls.dll  IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information about standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbWNet KbClientServer kbClientProtocols kbClient kbnetwork kbinterop kbSecurity kbQFE kbfix kbBug kbWinXPpreSP2fix kbWinServ2003preSP1fix KB827537 kbAudITPRO