"Sorry, Your System Is Not Working Properly" Error Message When You Try to Use the Internet Explorer Search Feature (827326)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows NT 4.0 SP6
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows 98 Second Edition
    • the operating system: Microsoft Windows 98


SOX030401700071
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you click Search on the Internet Explorer toolbar, you may not be able to access the Search Companion pane, and you may receive the following error message:
Sorry, your system is not working properly

CAUSE

This issue may occur if there is a corrupted registry key on your computer.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, delete the registry key that is causing the issue, and then restart your computer. To do this, follow these steps:
  1. Start Registry Editor. To do this, click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry key:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings\User Agent

  3. Right-click User Agent, and then click Delete.
  4. In the Confirm Key Delete dialog box, click Yes.
  5. Restart your computer, and then try to use the Search feature again.

Modification Type:MinorLast Reviewed:9/27/2004
Keywords:KB827326 kbAudEndUser