Event ID 677 and event ID 673 audit failure messages are repeatedly logged to the Security log of domain controllers that are running Windows 2000 and Windows Server 2003 (824905)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

In a Microsoft Windows Server 2003 domain, event ID messages that are associated with account logon failures may be repeatedly logged to the security event log on domain controllers. For example, the following event message is repeatedly logged on Microsoft Windows 2000-based domain controllers:Type: Failure Audit
Source: Security
Event Category: Account Logon
Event ID: 677
User: NT AUTHORITY\SYSTEM
Description: Service Ticket Request Failed:
User Name: UserName
User Domain: DomainName
Service Name: ServiceName
Ticket Options: 0x40830000
Failure Code: 0xE
Client Address: IPAddress
The following event message is repeatedly logged on Windows Server 2003-based domain controllers:Type: Failure Audit
Source: Security Event
Category: Account Logon
Event ID: 673
User: NT AUTHORITY\SYSTEM
Description: Service Ticket Request:
User Name: UserName
Domain: DomainName
Service Name: ServiceName
Service ID: ServiceName
Ticket Options: 0x40830000
Ticket Encryption Type: TicketEncryptionType
Client Address: IPAddress
Failure Code: 0xD
Logon GUID: GUID
Transited Services: ServiceName

CAUSE

This problem occurs because the Kerberos client on Windows 2000-based computers and on Windows Server 2003-based computers examines the Key Distribution Center (KDC) at set intervals to verify that the Service-for-User (S4U) Kerberos extension is supported. By default, the Kerberos client examines the KDC every 15 minutes. Because Windows 2000 does not support the S4U Kerberos extension, event ID 677 messages are logged to the security event log of a Windows 2000 domain controller. In Windows Server 2003, event ID 673 messages are logged to the security event log if the S4U Kerberos extension is not configured. To use the S4U Kerberos extension, you must have a Windows Server 2003 native domain, and you must configure the appropriate computer accounts for constrained delegation.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required for the Windows Server 2003 hotfix. The Windows 2000 hotfix requires Windows 2000 Service Pack 4 (SP4).

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003
   Date         Time   Version       Size     File name   Platform
   ---------------------------------------------------------------
   11-Nov-2003  20:51  5.2.3790.101  225,792  Kdcsvc.dll  x86
   11-Nov-2003  10:52  5.2.3790.101  584,704  Kdcsvc.dll  IA-64
Windows 2000
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   14-Nov-2003  23:56  5.0.2195.6824  124,688  Adsldp.dll
   14-Nov-2003  23:56  5.0.2195.6824  132,368  Adsldpc.dll
   14-Nov-2003  23:56  5.0.2195.6824   63,760  Adsmsext.dll
   14-Nov-2003  23:56  5.0.2195.6824  381,712  Advapi32.dll
   14-Nov-2003  23:56  5.0.2195.6866   69,904  Browser.dll
   14-Nov-2003  23:56  5.0.2195.6824  136,464  Dnsapi.dll
   14-Nov-2003  23:56  5.0.2195.6824   96,016  Dnsrslvr.dll
   14-Nov-2003  23:56  5.0.2195.6866   47,376  Eventlog.dll
   14-Nov-2003  23:56  5.0.2195.6871  148,240  Kdcsvc.dll
   05-Nov-2003  19:32  5.0.2195.6871  205,584  Kerberos.dll
   21-Sep-2003  00:32  5.0.2195.6824   71,888  Ksecdd.sys
   29-Oct-2003  06:45  5.0.2195.6869  511,248  Lsasrv.dll
   29-Oct-2003  06:45  5.0.2195.6869   33,552  Lsass.exe
   14-Nov-2003  23:56  5.0.2195.6866  307,984  Netapi32.dll
   14-Nov-2003  23:56  5.0.2195.6863  361,232  Netlogon.dll
   14-Nov-2003  23:56  5.0.2195.6874  931,600  Ntdsa.dll
   14-Nov-2003  23:56  5.0.2195.6824  392,464  Samsrv.dll
   14-Nov-2003  23:56  5.0.2195.6824  113,936  Scecli.dll
   14-Nov-2003  23:56  5.0.2195.6824  259,856  Scesrv.dll
   14-Nov-2003  23:56  5.0.2195.6824   48,912  W32time.dll
   21-Sep-2003  00:32  5.0.2195.6824   57,104  W32tm.exe
   14-Nov-2003  23:56  5.0.2195.6869  126,224  Wldap32.dll


Note This hotfix should be applied to the following computers:
  • Domain controllers that are running Windows 2000 or Windows Server 2003
  • Member servers that are running Windows Server 2003


WORKAROUND

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To work around this problem and to reduce the frequency of event ID 677 and event ID 673 event messages, increase the S4U cache timeout value in the Kerberos client on computers that are running Windows Server 2003:
  1. On a computer that is running Windows Server 2003, click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\Kerberos\Parameters

  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type S4UCacheTimeout, and then press ENTER.
  5. In the Value data box, type the number of minutes that you want to specify for the timeout value, and then click OK.

    Note By default, the S4U cache timeout value is 15 minutes.
  6. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Windows Server 2003 introduces support for constrained delegation in the Service-for-User-to-Proxy (S4U2Proxy) extension to Kerberos. By using the S4U2Proxy extension, a service can obtain tickets to another service for a user. For more information about S4U Kerberos extensions, visit the following Microsoft Web site: For more information about the LsaLogonUser function, visit the following Microsoft Web site: For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New Naming schema for Microsoft Windows hotfix packages

For additional information about terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinServ2003preSP1fix kbBug kbfix kbQFE kbWin2000preSP5fix KB824905 kbAudITPRO