Large UDP broadcast packets may not be received in Windows XP or in Windows Server 2003 (824838)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP 64-Bit Edition Version 2003
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002

SYMPTOMS

When a program sends a large User Datagram Protocol (UDP) broadcast packet, the packet may not be received.

CAUSE

When you send a UDP broadcast packet that must be fragmented, the IP checksum value may be calculated incorrectly. The computer that receives the UDP broadcast packet may identify the UDP broadcast packet as corrupted and discard the UDP broadcast packet. A UDP broadcast packet is fragmented when the UDP broadcast packet is larger than 1,500 bytes on an Ethernet II network. This problem originates on the Windows XP-based computer or on the Windows Server 2003-based computer that sends the packet.

RESOLUTION

Hotfix information

Windows XP Service Pack 1 and Service Pack 2

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Prerequisites

You must have Windows XP Service Pack 1 (SP1) or Service Pack 2 (SP2) installed.

Restart requirement

You must restart your computer after you install this hotfix

Update replacement information

This hotfix does not replace any other hotfixes

File information

Windows XP 32-bit versions, SP1
Date          Time   Version        Size     File name
------------------------------------------------------
18-Jul-2003   12:38  5.1.2600.1250  318,720  Tcpip.sys
Windows XP 64-bit versions, SP1
Date         Time   Version        Size       File name
--------------------------------------------------------
18-Jul-2003  12:38  5.1.2600.1250  1,092,992  Tcpip.sys
Windows XP 32-bit versions, SP2
Date         Time   Version            Size    File name
--------------------------------------------------------------
19-Aug-2004  07:00  5.1.2600.2507     359,040  Tcpip.sys

Windows Server 2003

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Windows 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you install this hotfix

Update replacement information

This hotfix does not replace any other hotfixes

File information

Date         Time   Version           Size    File name
--------------------------------------------------------
14-May-2004  18:26  5.2.3790.172   334,336    Tcpip.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/28/2005
Keywords:kbHotfixServer kbQFE kbWinXPsp2fix kbQFE kbWinXPpreSP2fix kbfix kbbug kbprb KB824838 kbAudITPRO