ASP File Cache Is Deleted After a Network Error (824322)



The information in this article applies to:

  • Microsoft Internet Information Services version 6.0

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry


SYMPTOMS

Active Server Pages (ASP) caches the files that it serves, and ASP uses change notifications to determine when a cached file must be updated. When the content lives on a remote Universal Naming Convention (UNC) share, Internet Information Services (IIS) may return HTTP 500 error messages to the client.

CAUSE

When a netwok error occurs between the IIS server and the remote file server, the file is deleted from the ASP cache. If the client requests the ASP page again, IIS returns HTTP 500 error messages to the client.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

After you install this hotfix, you must restart IIS.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------
   15-Aug-2003  19:01  6.0.3790.77       379,904  Asp.dll          


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

After you apply this hotfix, you can control its behavior through the following registry key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ASP\Parameters\DisableCachedResponseOnUNCAccessFailure By default, the value of this key is set to 0 (that is, the new behavior is enabled). To disable this behavior, set the value of this key to 1.

Modification Type:MinorLast Reviewed:10/26/2005
Keywords:kbHotfixServer kbQFE kbHotfixServer kbQFE kbWinServ2003preSP1fix kbQFE kbBug kbfix KB824322