Wireless and VPN Clients Cannot Successfully Authenticate by Using EAP-TLS Authentication (824069)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

Wireless and virtual private network (VPN) clients may not be able to successfully authenticate by using Extensible Authentication Protocol-Transport Layer Security (EAP-TLS) authentication through a Microsoft Internet Authentication Service (IAS) installation on a Microsoft Windows Server 2003-based server.

CAUSE

This problem may occur if IAS picks a certificate that is not valid for network access authentication -- for example, a certificate that contains a blank subject name. The selection of the certificate that is not valid causes TLS negotiations to fail both for VPN and for wireless connections.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size      File name     Platform
   ------------------------------------------------------------------
   08-Aug-2003  19:32  5.2.3790.75   158,208   Rastls.dll    i386
   08-Aug-2003  19:33  5.2.3790.75   353,280   Rastls.dll    IA-64
   08-Aug-2003  19:32  5.2.3790.75   158,208   Wrastls.dll   IA-64 

WORKAROUND

On your server (or servers) that has IAS installed, open the remote access policies that use EAP, and then manually select the correct certificate.

STATUS

Microsoft has confirmed that this is a problem in Windows Server 2003.

Modification Type:MinorLast Reviewed:10/27/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE kbWinServ2003preSP1fix KB824069 kbAudITPRO