Windows Server 2003 Does Not Identify a Dell PV122T VS80 Medium Changer (823211)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

SYMPTOMS

A Windows Server 2003-based computer does not identify a Dell PV122T VS80 medium changer device. The device stops working after this problem occurs. The PV-122T VS80 appears as Benchmark VS640 DLT Autoloader in Device Manager. If you upgrade your firmware from V50 to V57 on the PV-122T VS80, you may experience this problem.

CAUSE

This issue is caused by a code problem in the Microsoft-provided Powerfil.sys driver. When a MoveMedium command is issued, Windows first determines if the transport, source, and destination element are out of range. A transport address is considered to be out of range if no transports are being reported. The driver does not identify the device if no transports are being reported.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name     Platform
   ---------------------------------------------------------------
   08-Jul-2003  00:09  5.2.3790.68  11,264  Powerfil.sys  x86
   08-Jul-2003  00:09  5.2.3790.68  30,208  Powerfil.sys  IA64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how hotfix packages are named , click the following article number to view the article in the Microsoft Knowledge Base:

816915 New Naming Schema for Microsoft Windows Hotfix Packages


Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbStorageDev kbDDK kbBug kbfix kbQFE kbWinServ2003preSP1fix KB823211 kbAudDeveloper kbAudOEM