You receive a <font name> not found error message when you use Acrobat Distiller to distill a PostScript file that was created by Publisher 2003 (822978)



The information in this article applies to:

  • Microsoft Office Publisher 2003
  • Microsoft Office Publisher 2003 with Digital Image Pro

SYMPTOMS

When you try to use Adobe Acrobat Distiller to distill a PostScript file that was created by Microsoft Office Publisher 2003, you may receive an error message that is similar to the following:
%%[ ProductName: Distiller ]%%
%%[ Error: Times-Roman not found. Font cannot be embedded. ]%%
%%[ Error: invalidfont; OffendingCommand: findfont ]%%

Stack:
/Font
(Times-Roman)
true
/256
0
/F0
false
/Times-Roman

%%[ Flushing: rest of job (to end-of-file) will be ignored ]%%
%%[ Warning: PostScript error. No PDF file produced. ] %%
Distill Time: 1 seconds (00:00:01)
**** End of Job ****
Note The error message that you receive may list Helvetica instead of Times-Roman.

CAUSE

This problem occurs because the printer driver has Helvetica and Times-Roman as printer resident fonts and the printer driver is configured to substitute device fonts for certain TrueType fonts. Printer resident fonts are fonts that are resident on the printer and not on your computer. Acrobat Distiller does not have the font outlines for Helvetica and Times-Roman, and that causes it to generate the error message.

Note This error message may appear even if the following conditions are true:
  • The publication does not appear to contain Times-Roman or Helvetica.
  • The Use Only Publication Fonts option on the Graphics and Fonts tab of the Advanced Print Settings dialog box is selected.

RESOLUTION

To work around this problem, use one or both of the following methods.

Method 1: Configure the Printer Driver Not to Substitute Fonts

To resolve this problem for the current publication, follow these steps:
  1. On the File menu, click Page Setup.
  2. Click the Printer and Paper tab.
  3. Click the name of the printer that you will be using, and then click Properties.
  4. Click Advanced.
  5. In the Graphic section, change the TrueType Font option to Download as Softfont.
  6. Click OK, and then click OK.
To prevent this problem from occurring for all current publications, follow these steps:
  1. Click Start, and then click Printers and Faxes.
  2. Right-click the printer that you want to configure, and then click Properties.
  3. Click Printing Preferences.
  4. Click Advanced.
  5. In the Graphic section, change the TrueType Font option to Download as Softfont.
  6. Click OK, and then click OK.

Method 2: Configure Acrobat Distiller to Ignore the Error Message

You can configure Acrobat Distiller so that you still receive an error message, but the error message does not prevent a PDF file from being created. These steps apply to Acrobat Distiller 6.0.

If you are using a different version of Acrobat, the procedure will be slightly different. See your documentation to determine the version that you have. To configure Acrobat Distiller 6.0 to ignore the error message, follow these steps:
  1. Click Start, point to All Programs, and then click Acrobat Distiller 6.0.
  2. On the Settings menu, click Edit Adobe PDF Settings.
  3. Click the Fonts tab.
  4. On the When Embedding Fails list, click Warn and Continue.
  5. Click OK.
  6. When Acrobat Distiller prompts you to save a new settings file, do so.

    Acrobat Distiller will suggest a name that is similar to the following:

    Press Quality(1).joboptions

When you use Acrobat Distiller in the future, use the new settings file that you just created.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:1/12/2006
Keywords:kbFont kbprint kb3rdparty kberrmsg kbprb KB822978