BUG: Driver installation program does not install device drivers (822831)



The information in this article applies to:

  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP4

SYMPTOMS

Some driver installation programs do not work on Microsoft Windows 2000 after you install either Critical Update QFE 814033 or Microsoft Windows 2000 Server Service Pack 4. The installation does not succeed, and you receive an incorrect error message that no drivers are available for the device. The %WINDIR%\Setupapi.log reports that there are no compatible drivers for the device.

CAUSE

This problem occurs when the .inf file for the driver that is being installed already exists in the default INF directory. However, the driver that is being installed is not the currently installed driver for the device.

The .inf file for the new driver that you are trying to install may have been placed in the INF directory by the SetupCopyOEMInf() function, or the driver may have been previously installed and then removed, leaving the .inf file behind. In this scenario, the UpdateDriverForPlugAndPlayDevices() function is unsuccessful and incorrectly gives an error that no drivers are available for the device.

RESOLUTION

The following file is available for download from the Microsoft Download Center:
DownloadDownload the Windows2000-KB822831-x86-ENU.exe package now. Release Date: August 13, 2003

For more information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/25/2005
Keywords:kbHotfixServer kbQFE kbQFE kbPlugPlay kbbug KB822831 kbAudDeveloper