Remote Procedure Call Over HTTP Is Not Successful or Reverts to TCP (822594)
The information in this article applies to:
- Microsoft Exchange Server 2003 Enterprise Edition
- Microsoft Exchange Server 2003 Standard Edition
SYMPTOMS
When you try to connect to Microsoft Exchange Server 2003 by using a remote procedure call (RPC) over HTTP connection, the connection may not succeed, or the connection may revert to a TCP (Transmission Control Protocol) connection.
CAUSE
This issue may occur if you try to connect to the Exchange server by using Microsoft Outlook with Secure Sockets Layer (SSL) enabled.
This issue occurs if the server-based certificate is issued to a different server than the one that you are trying to connect to.
For example, if you have configured Outlook to use https://mail.example.com as the default RPC over HTTP proxy server, but the certificate is issued to a front-end server such as frontend.example.com, the connection is not successful because the client does not recognize the front-end server as a valid server to authenticate with.RESOLUTION
To resolve this problem, follow these steps:
- On the RPC Proxy server computer, click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
- Expand your domain, double-click Default Web Site, right-click RPC, and then click Properties.
- Click the Directory Security tab, and then click View Certificate.
- Make sure that the certificate is issued to the same server that is used by the client.
If you have to, modify the RPC Proxy setting on the Outlook client, or obtain a new certificate for the RPC Proxy server computer.
STATUS Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 11/7/2005 |
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Keywords: | kbExchangeOWA kbBug KB822594 kbAudITPRO |
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