SMS: Collection Created with the Systems Management Server Software Development Kit Is Missing Members (822536)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you use an Systems Management Server (SMS) 2.0 software development kit (SDK) script or program to create a new SMS collection, the collection may be empty or only partly populated until the SMS Collection Evaluator refreshes the collection.

CAUSE

This problem occurs because the SMS Collection Evaluator refreshes a new collection before the SDK script or program has added the complete set of query-based membership rules. The problem only occurs with collections that have query-based membership rules and most frequently occurs on collections that have many membership rules.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name     Platform
   --------------------------------------------------------------------
   
   25-Aug-2003  20:35  2.0.1493.4216  1,587,104  Basesvr.dll   X86
   25-Aug-2003  20:35  2.0.1493.4000     82,064  Cmprov.dll    X86
   25-Aug-2003  20:35  2.0.1493.4213     91,536  Colleval.dll  X86
   25-Aug-2003  20:35  2.0.1493.4105    121,440  Compmgr.exe   X86
   25-Aug-2003  20:35                     1,318  Update.sql    X86
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

Installation Information

Modify the Registry

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To fix this problem, you must add a new registry value to each of the affected primary sites and install the hotfix. To modify the registry, follow these steps:
  1. Start Registry Editor.
  2. Locate the following key in the registry:

    HKEY_LOCAL_MACHINE\Software\Microsoft\SMS\Components\SMS_COLLECTION_EVALUATOR

  3. Click the key, on the Edit menu, click Add Value, and then add the following registry value:

    Value name: ADC Processing Delay
    Data type: REG_DWORD
    Value data: Number of seconds

    The "ADC Processing Delay" value sets how many seconds SMS Collection Evaluator waits for query-based collection membership rules to be added to the database when a new collection is created. The default value is 0. However, a value of 0 causes the same behavior as without the hotfix. SMS Collection Evaluator accepts a value up to 120 seconds.

    For example, if you set the ADC Processing Delay value to 10, and then restart the SMS_EXECUTIVE service, SMS Collection Evaluator waits for up to 10 seconds after it receives an ADC file before it refreshes the collection. This gives the script or program that creates the collection time to finish adding query-based membership rules.
  4. Quit Registry Editor.
  5. Restart the SMS_EXECUTIVE service.

Use the Hotfix Installer to Install the Hotfix

Note This method is only for Intel-based computers.
  1. Create a folder in a location that your SMS site servers can access.
  2. Copy the SMS2.0-SPX-KB822536-X86-ENU.exe update file (where X is the service pack version) to the new folder.
  3. From each of the primary and secondary SMS site servers in your environment, use an account that has administrative credentials to log on to your site server.
  4. Quit the SMS Administrator console if it is running.
  5. Run the SMS2.0-SPX-KB822536-X86-ENU.exe program(where X is the service pack version), and then follow the instructions in the wizard.

Manually Install the Hotfix

Manually Update the SMS Site Server
  1. Create a folder in a location that your SMS site servers can access.
  2. Run the following command:

    SMS2.0-SPX-KB822536-X86-ENU.exe /x

    where X is the service pack version)
  3. Extract the hotfixed files to the folder that you just created.
  4. From each of your primary and secondary SMS site servers in your environment, use an account that has administrative credentials to log on to your site server.
  5. Quit the SMS administrator console.
  6. Stop all the SMS services.
  7. In the SmsRootFolder\bin\Platform folder, open a command prompt, and then type the following command:

    regsvr32 /u Cmprov.dll

  8. Copy the updated files from the disk or network share to the SMS installation folder:
    • SmsRootFolder\bin\Platform\Basesvr.dll
    • SmsRootFolder\bin\Platform\Cmprov.dll
    • SmsRootFolder\bin\Platform\Colleval.dll
    • SmsRootFolder\bin\Platform\Compmgr.exe
  9. In the SmsRootFolder\bin\Platform folder, open a command prompt, and then type the following command:

    regsvr32 Cmprov.dll

    Note This hotfix also contains a SQL script to update the SMS database. If the SMS site server and the SQL server run on separate computers, run the script on the remote computer that is running SQL Server.
  10. Load the Update.sql script. To do so, use a SQL server query tool, such as Query Analyzer or ISQL/W.
  11. In the SQL server query tool, click the SMS database, and then run the script.
  12. Restart the SMS services.
  13. Reset the installation. To do this, follow these steps:
    1. Click Start, point to Programs, point to Systems Management Server, and then click SMS Setup.
    2. Click Next, click Next, and then click Modify or reset the current installation.

Additional Installation Information

To install this hotfix on remote site computers such as SMS administrator consoles, an SMS SQL monitor, or an SMS provider that is not located on the site server, use the appropriate method.

Manually Installing the Hotfix on a Remote SMS Administrator Console

Note Before you install this hotfix on your SMS administrator console, you must install it on the SMS site servers that are in your environment.
  1. Quit the SMS Administrator console, if it is running.
  2. Replace the following files in the SMS_Admin_Root\bin\Platform folder with the versions from the hotfix:
    • SMS_Admin_Root\bin\Platform\Basesvr.dll
    • SMS_Admin_Root\bin\Platform\Cmprov.dll
    • SMS_Admin_Root\bin\Platform\Compmgr.exe

Manually Installing the Hotfix on a Remote SMS Provider Server

Note Before you install this hotfix on your SMS provider server, you must install it on the SMS site servers in your environment.
  1. At the SMS Provider server, stop the following services:
    • SMS_SQL_MONITOR_SERVERNAME
    • Windows Management

      Note With WMI build 1085, the service name has been changed to "Windows Management Instrumentation".
  2. Replace the SmsRootFolder\bin\Platform\Basesvr.dll file with the version from the hotfix.
  3. Restart the following SMS Provider services:
    • SMS_SQL_MONITOR_SERVERNAME
    • Windows Management

      Note : With WMI build 1085, the service name has been changed to "Windows Management Instrumentation".

Manually Installing the Hotfix on a Remote SMS SQL Monitor Server

Note Before you install this hotfix on your SMS SQL Monitor Server, you must install it on the SMS site servers in your environment.
  1. At the SMS SQL Monitor Server, stop the SMS_SQL_MONITOR_SERVERNAME service.
  2. Replace the SmsRootFolder\bin\Platform\Basesvr.dll file with the version from the hotfix.
  3. Restart the SMS_SQL_MONITOR_SERVERNAME service.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

WORKAROUND

You may be able to avoid this problem by adding several seconds delay (typically 5 to 10 seconds) to the script or program that creates the collection. Add the delay in one of the following two locations:
  • Before calling the AddMembershipRules method in the SMS_Collection class.
  • Before calling the RequestRefresh method in the SMS_Collection class.

MORE INFORMATION

This hotfix adds the configurable ADC processing delay and introduces a change that makes sure that SMS Collection Evaluator always uses the up-to-date collection rule data.

Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE KB822536